Ugly Displacement Cracks Fix

Hi all,

I was wondering if anyone had a fix for the following issue seen at the bottom of this screenshot. Ugly displacement cracks. Beyond placing a plane under the landscape material, is there a way to preserve the height of the landscape material tessellation without having these ugly breaks?


Check “Crack free displacement” in your material.

Edit: And uncheck Adaptive Tessellation.

Check Positive Z Bounds Extension property on your Landscape actor and increase it a bit

For me, checking “Crack Free Displacement” gave me cracks

Same here, “crack free displacement” made it worse but what worked for me was setting the “max displacement” setting in the material from 0 to 100 (played around with the value until it was gone). In case anyone else has the same issue with gaps due to the near tesselation transitioning too fast to the non-tesselated landscape material

1 Like