Ugly compression

Hi, is it possible to make ugly compression not happen? I am working on a simple hand painted rock texture and wanted to see how it currently looked in the engine, and the compression really shocked me.

Fresh reimport of the texture (showing it uncompressed)

After saving (which auto compresses)

Change the ‘Default’ compression settings to use either BC7 (Compressed, which is a better format anyway), or VectorDisplacementMap (which is uncompressed). There are some advantages/disadvantages to both. I did a stream on Texture Compression a while ago, check it out here (sorry, no YouTube upload :()

Compression is just something you have to learn to live with, but if it’s really important that a texture isn’t compressed then it’s fine to use these options every now and again.