UEeditor crashes when trying to apply Hydro Erosion to landscape

How I can reproduce it:

  1. Create new project, blank, doesn’t matter if it has starter content or not
  2. Select “Landscape” → Manage → press “Create” button
  3. Select “Landscape” → Sculpt → choose Hydro Erosion → click anywhere on the landscape

It crashes:

/home/username/soft/UnrealEngine/Engine/Binaries/Linux/UE4Editor: symbol lookup error: /home/username/soft/UnrealEngine/Engine/Binaries/Linux/libUE4Editor-LandscapeEditor.so: undefined symbol: kiss_fftnd_alloc

This happens on Linux - opensuse 13.2 x86_64, Unreal Editor 4.7.2

My system spec is as follows:

  • Intel(R) Core™ i5-3570K CPU @ 3.40GHz
  • 8 gigabytes RAM
  • NVIDIA GTX 670

I have the same trouble in Kubuntu 14.04.1 x86_64, Unreal Editor 4.7.1. PC config is:

  • CPU AMD Phenom II X6 1055T 2.8 GHz
  • 4 Gb RAM
  • Nvidia GTX 550 Ti

I attempted this on my end but have thus far not been able to reproduce it. Do you have a project that is experiencing this error that you’d be willing to share? I’ll be happy to take a look!

This happens with any project for me. I can create a new project and this happens. Do you still want me to share it?

If it is happening in a blank project with no additional content then it won’t help significantly. It seems as though this may be limited to Linux, do you have a Windows machine you can attempt this on? I tried the hydro erosion with maximum brush size and settings and didn’t see any errors.

I don’t have a windows machine. Yes, it happens in a blank project.

No one of Windows users that I know can’t reproduce this trouble. But 100% of Linux users do. With different distros and PC configurations. So, this is definitely Linux specific bug.

Hi everyone,

I was able to reproduce this and have entered a bug report, UE-11828 to be assessed by the development staff.

Mind if I ask, where can I see that report and progress on it?

At present we do not have a public bug tracker.

KissFFT was not built for Linux. Thanks to pull request #937 by yaakuro this omission has been corrected and the tool works as of this commit: https://github.com/EpicGames/UnrealEngine/commit/8f77f546ae7740ba420729e4f58df35757bcfb46

I wonder, was it removed or something like this? Because I still face this bug in 4.7.3.

No, this fix was not applied to 4.7.x branch. I’ll follow up internally on possibility of merging it.

OK, thanks. I almost was going to redownload and compile Editor ^_^.

The fix was merged to 4.7.x branch.

Great! Will update soon.

It’s going to be in the next patch release (4.7.5)