Download

UEditableTextBox BindWidget not being found

Hello all,

I have a simple C++ class that extends UUserWidget, and I am getting an error that my widget binding cannot be found.

However, I am only getting this error with the UEditableTextBox object. For example, here is how I am bind these properties:




UCLASS()
class CHATROOM_API UMainMenu : public UUserWidget
{
    GENERATED_BODY()
private:

    UPROPERTY(meta = (BindWidget))
    class UButton* JoinButton;

    UPROPERTY(meta = (BindWidget))
    class UEditableTextBox* IPAddressField;
}


I have the actual objects named the same as those properties in the BP designer.

I get an error on the Text Box, but not on the button, saying that it is not found.

Here are the things that I have tried so far:

  • Recompiling the project from Visual Studio 2017 and using UE4’s hot reload.
  • Reset the project
  • Delete the widget BP and make another one (results in the same thing happening)

I am using UE 4.18.2, Windows 10, and Visual Studio 2017 enterprise

Anyone have any idea on next steps for trouble shooting, or what this could be?

Thanks!

I came here looking for a solution as I am having the exact same issue.

I take it this is from the Udemy tutorials on C++ multiplayer?

I think its a bug in blueprint as it sometimes works if you strip the blueprint and rebuild it from scratch.

i dont know why it occours but its frustrating as hell, as binding widgets in C++ is a pretty standard thing to do and it happens to me all the bloody time.

Help

I have the same issue. Any other solutions than building the BPs again?
Here is the AnswerHub link UEditableTextBox is not bindable? - UE4 AnswerHub

Ok, I am a ******. In my WidgetBP(Layout) I used EditablText and not EditableTextBox. They are different. Check if youre using EditableTextbox in your layout. Sry, my bad.

I had this issue as well. First thing I tried was rebuilding the solution and that didn’t help. I tried closing and opening the editor as that is sometimes a solution but it wasn’t this time. Finally I just renamed the widget something else in editor, when I compiled it obviously gave me an error as my c++ expected the original name. So I renamed it to the original name in editor, complied and it worked. I think the last few steps is all you need to do but idk haven’t tested it as this issue is rare.