[UE501] Smart objects seem broken?

Followed the tutorial here:

With one instance of the AI in my scene, it seems to broadly work. With two I noticed neither of them were detecting any smart objects (I debugged the BTT_FindSmartObject and at the point where they try to do a ‘find smart objects’ and they come back with zero results in the array).

I’ve tried a few other situations and got really weird results - e.g. If I have 10 smart objects in my scene and add a new one - they might return 11 results, or sometimes 2 [its different each time I launch or depending if i recently removed/added a smart object to my scene or another AI].
Definitely not the nav box, or the size of the search box i’m passing into my query causing this.

After playing around for about an hour, I now end up crashing the program anytime I try to debug the return objects from find smart objects or look at smart object attributes e.g. the smart object handle each unique item has.

I don’t really see many posts on the forum about smart objects, so I wanted to ask is this experience shared by others too?


I have a similar problem! Were you able to solve it?

Afraid not. Though I haven’t tried since 5.01 mainly because I haven’t seen it mentioned in any changelogs for 5.02 or 5.03 as having had anything fixed about it. Interestingly I did download the matrix demo and they have quite heavy usage of smart objects for benches etc and I sat for a good 10 minutes debugging them in simulation and they act very oddly there too but at least do sometimes work…