Download

UE5 Weird viewport flashes

Since UE5 EA came out I’m having these weird flashes on the viewport. I’m using a GTX 1070 Ti. What could this be?

Version: 5.0.0-16682836+++UE5+Release-5.0-EarlyAccess

Check your system requirements. ue5 needs a pretty beefy computer compared to ue4.

1070 ti is pretty low end gfx card. I have a RTX 2060 and it sometimes struggles with ue5.

also RAM matters and anything lower than 32gig is going to run poorly

and low end cpus like an i3 / i5 seem to struggle with ue5.

@frostic , NBraz is getting 88fps in that screenshot so I’m not sure it is performance that is his problem (specifically with this scene) - though I agree 100% with the needing beefy computer comment.

@NBraz is this a fresh UE5 project or one converted from a UE4 project. I wonder if it is something odd with the roughness or normals on the table.
Have you created the same scene if 4.26 to see if the same issue exists.

1070ti is not a low end card, it’s pretty capable. And whether or not you need 32GB or more is up to what project you’re doing. Having more RAM isn’t going to make things faster if you don’t need it.

Most likely this glitch is a GPU drivers issue, make sure you’re on the latest Nvidia drivers and consider some of your PC configuration settings that might have an impact on your GPU including other programs that are running.

NO…Hes getting a frame drop from 88 to 71 when the issue happens… and high game thread ping. it is system performance drop…

@frostic sorry I thought he was talking about the weird flashes at the bottom of the screen on the first screenshot, not that the scene was flashing blue… I thought the second screenshot was just demonstating it wasn’t happening in another rendering mode / post process etc.

No. it is not. not by any means. 1080 ti is low by industry standard. everyone running lower than an rtx 2060 Is having major issues with running UE5… and RAM does have a performance issue as you don’t know how many apps he has running in the background you don’t know if he is maxing out his ram causing it to use a swapfile that would rip down performance badly if hes low on ram… if you run minimal specs on 8gig ram like i did 5 years ago with a 1070 ti you would know why. i been there. done it, had it and upgraded due to the issues it has using such a lower grade hardware spec.

Thank you for all the suggestions guys and sorry for not detailing the problem correctly!

This is running with a dual Xeon 2699V3 with 32Gb of RAM and a GTX 1070Ti, so I don’t think it is a performance issue. At first, my suspicions were the GPU driver, I updated it and it didn’t solve the problem. I’m also running it remotely with Parsec. Can’t remember if I actually tried locally but I guess I already tried that just to rule out Parsec and if I remember correctly it did exactly the same thing.

The artifacts you see on the bottom of the first frame are always present when moving around the viewport and sometimes shift to other corners. What you see on the second frame are the flashes that occur every 3 seconds or so.

I’ll keep an eye on ram usage and get back with a video. Don’t think the problem lies there either but I’ll check further.

EDIT: Ram usage is at 23%. No problems there apparently.

EDIT 2: The scene is the Archviz scene converted to Lumen and UE5.

EDIT 3: Video here: 2021-07-17 20-41-20

Bloom is causing the issue by the way, so turn it off in PostProcess

1 Like

@Bladerskb That was exactly it! Convolution Bloom Method was causing it. Turning Bloom off or changing the method to Standard solves the issue. Many thanks!

Sure, 8GB might be an issue, but again, it depends on what he’s doing. You made a blanket statement that anything less than 32GB wouldn’t run well, and that’s not in any way correct.
And no, 1070ti is not low end at all, it’s certainly not designed for ray tracing but it’s still a fairly powerful card.
And you can see that the issue wasn’t even related to his GPU performance