UE5 static spot light not working

Hello,

The static spot light is not working and the only solution I found is to change “Lumen” from “None” under Project Setting > GI, however this doesnt work for my scene.

Any advise?

Leo

Some additional info if thats matter:
I started my scene with a default template, under archi or game (forgot which one exactly, let me know if thats matter) and I didnt change other project setting, including the world lightmass setting, googled a few discussions and seems I am not the only one have this issue and quite shocked that static spot lighting could be an issue which I think this is quite a basic function for every industry.

My scene



FYI.

this is the solution I found online but sadly doesn’t work for me. Posting it here if it helps.

Guess I am not the only one having this problem, any hint please :smiling_face_with_tear: ?