UE5 Source not compressed correctly? What?! (multiple bugs)


First download mysteriously “failed” 3 minutes in, when I tried downloading again it started a new download. What the hell is this? I’ve installed the source version before and never had this issue or failing downloads then a subsequent issue like this. The download I’m referring to is the compressed source engine from github repo.

The only reason I’m downloading the source engine is because my spline class mysteriously broke itself in real time while nothing was running in the engine. I literally watched the subclass to select your static mesh the spline uses disappear. Programs don’t break themselves without input or hardware failure, of which neither occurred.

EDIT: tried redownloading from github, same results. This isn’t on my end.

EDIT2: Tried github instead, wow another critical bug! all within 2 hours of each other? Each of these download functions has its own branch of code, not a chance all these bugged at the same time. I got through most of the download on github then fail, so its connecting fine, the connection is being interrupted.

EDIT3: So wheres the subclass for the static mesh on the spline class? lol? My default blueprint breaks itself on the binary engine then when I try to download the source client so I can pop into visual and fix the stupid spline class… all my attempts to download meet equally strange and unprecedented bugs all within a matter of hours across multiple platforms/programs and completely different branches of code.

The spline class was fine up until I tested my child subclass and all was well, proceeded to create another subclass for water effects and watched the master classes default class options “static mesh” disappear and now the class options look like what you see.

I verified the issue was with the root code by creating a new BP and tried adding a spline component, showed the same thing. The ability to use the spline class was completely destroyed with this “bug” out of nowhere, and then countless other bugs when trying to download the solution.



EDIT:4
oh and my boolean tool stopped working correctly too apparently? lol? it worked fine yesterday when I made the block out of the doorway mesh you see behind the mesh I’m trying to boolean into a new door… it shouldn’t be leaving the remainder above the doorway. It should be a perfect loaf like the block you see to the right I made yesterday without problem. I did have a couple instances of bugs when placing blocks, but nothing that outright stopped all progress.