UE5 Sequencer Audio DE-SYNC issue with clock set to Tick & cracking / popping when clock set to Audio


I am running into an issue with audio in the UE5 sequencer. I have my .wav file set to PCM for seeking, that’s all good. But I can see the audio is lagging. For instance when you hit play, it plays in time for a little bit, but over time it goes out.

So in this image attached the waveform that is coming up starts playing where the playhead is, earlier than it should be. But if i stop and play again, it starts where it should but then slowly goes out of time again.

I have everything set to 60fps in the project, both the sequencer and in the advanced options.

I found a fix to this where I set the sequencer clock from Tick to Audio. This locks in the audio clock for the sequence, it makes everything in time, perfect.

But what happens now is there is a lot of cutting in and out, clicking and popping throughout the audio track.

I thought maybe this was to do with the sample rate, so I set everything to be the same, 44100kHz and also tried 48000kHz, but still the same issue.

Audio plays really smooth when clock is set to Tick - but it’s out of time, making it a nightmare to build cinematic sequences around the audio.

When clock is set to Audio - perfectly in time, but the whole audio track is shot.

Am I missing something here, any ideas??


I get similar issues if I use any other compression type than ADPCM. This also lines up with the seeking behaviour in the metasound waveplayer so while I can’t be sure that this is the exact issue it seems to at least be related.

This project has been moved from 4.27 to 5 so I thought I best create a new project in 5 and see if I can replicate the issue. I did so and everything works fine in a new project. So it might have something to do with my project, but also what I have noticed is that even with DLSS active in 5, the project has gone from a nice locked in 60fps to now 21fps, and we are seeing people online talking about optimization issues and terrible fps going on at the moment.

So I am gonna stick with 4.27 for the meantime until things get ironed out a bit in 5.


I had the same issue on 4.27, looked like every cpu time on the main tick thread was slowing the sequence time and resulting on desync when the clock source was set to Tick.
When switching the clock source to Platform or Audio, the time is perfectly in time with the system clock and the audio is played without dilation but for some reason Unreal looks like trying to resync anyway even if it’s not needed.
Fixed it by using the console command :
Sequencer.Audio.UseAudioClockForAudioDesync 1

1 Like