UE5 "SDK for IOS is not installed properly"

Upon attempting to package to iOS from UE5, I receive the message “The SDK for IOS is not installed properly, which is needed to generate data. Check the SDK section of the Launch On menu in the main toolbar to update SDK.”

Attempting to package anyway results in the error “Error: IOS: Unable to find any Sdks that could be installed”

I am on a Windows 10 machine and usually use an old Mac for remote builds. Packaged this same project many times in UE4.27.

Thus far I have tried: making sure the MacOS and Xcode versions are adequate, updating .NET on windows, packaging to windows (works) and android (works).

Any ideas? I have seen questions and solutions for this problem with windows and android, but not iOS.

1 Like

Figured it out! I was using an old version of iTunes (, updating to the latest version of iTunes for Windows now allows me to build to iOS. Had the old version from back in the install-UE4-apps-via-iTunes days.

Good day,
May I know how you fix it with iTunes… I’m having the same exact problem as yours but I can’t fix it. Thank you

Hallo all, I have the same issue. In unreal 5, opening my project on windows 10 with Visual Studio 2022 , I can see under Platform->IOS->SDK Management the “Installed SDK 1497.1.14.1” The maximum “Allowed Version” is 1399.0 Does anybody know, where I can downgrade the SDK? Where is the path to the IOS SDK ? I have tried to install older iTunes Versions without success. I will try to solve this … But if somebody can help I’m happy. Have fun Olaf.


Hello, I have also encountered the same problem, which has hindered me for a long time. Have you solved this problem?


i’m having the same problem… fail to package iOS in UE5.0.3 on windows10

1 Like

does anyone ever find this problem for working with UE on windows? not sure what one is supposed to do when there is no option to install an iOS SDK and there is no one to contact at UE? UE is only programmed to install SDKs for Android, is this just confirmation that you cannot package for iOS through windows PC and you need mac/xcode? would be odd given the documentation says all you need is iTunes… which I have the latest installed…


i’ve followed

in the documents reads

Blueprint-Only iOS Projects on Windows

If you are creating a Blueprint-only iOS project, you do not need to use the full remote-build process detailed in the sections below. Instead, you can use your Windows machine to create your iOS build directly…

i’ve created project using template " third person "… added provision & certs

but when compile i gets the SDK warning… even i try to link to a mac for remote compile it still gives me the SDK warning… and proceed it gives “packaging complete” but no package in the selected folder

We’ve got stuck on this problem as well and couldn’t find an answer online so I will share how we’ve managed to solve it. The problem was that the newest version of iTunes had a newer version of the SDK than what Unreal Engine expects.

Oddly enough degrading the version of iTunes didn’t solve it and the iOS SDK version as displayed in Unreal Engine stayed the same. It turned out you have to delete iTunes as well as the app installed: “Apple Mobile Device Support” This app seem to get installed along with iTunes without you really knowing about it.

Only after deleting both and reinstalling this version of iTunes iTunes 12.10.11 for Windows (Windows 64 bit) could we build successfully again.

1 Like

I’m currently using which works fine when packaging in other versions of UE but gives me the sdk error in 5.1, really strange that 5.1 would require an older sdk than previous versions of UE4

Ok worked out I don’t have the right version of xcode installed for 5.1, I need 13.4.1 as the minimum but my old af mac won’t support it so guess i need to buy a new mac that supports the Monterey OS so I can install the right version of xcode :unamused:

1 Like

Did not update anything on my Mac.

I just uninstalled itunes 12.12 and installed the itunes from @66Gramms . Thank You :slight_smile:

i get this error too

The SDK for IOS is not installed properly, which is needed to generate data. Check the
SDK section of the Launch On menu in the main toolbar to update SDK.

But i use Macbook Air with M1 and OSX Monterey. It has not iTunes
How can fix this error on Mac?

had this several time while trying to package for ios from pc on mac remote, after crash mostly and as it was packaging just fine before , so refresh platform status fix for me

Hi NoahBeggs
I know you have already got solved. I am struggling to build Distribution iPA from Windows OS. You said you are using Remote MAC for remote builds. Do you use VM ware Mac OS? Can you explain how you configure remote session?
I followed many links for remote build, but I could not generate SSH. Thanks

Uninstall Apple Mobile Device Support,and install 12.10.11 Itunes.This problem solving!

1 Like