UE5 Preview 1 - Transluscent materials not behaving as expected

I just switched to UE5 Preview 1 from EA3 today for my project, and while the overall look is better, I find transluscent materials (windows, in my case) don’t behave as they should. They still cast shadows as if they were opaque, and look way too bright like they were accumulating light if their color is not black.
My understanding is that transluscent materials should behave correctly with Preview 1, so what is happening here ? Can it be because my project was previously created with EA3, and somehow some settings that should be changed persisted with Preview 1 ?

EDIT: after doing some tests in a project from scratch, with a simple closed box with a transparent window, I see the same issues. Light doesn’t go through the transparent mesh. Am I missing something ?

1 Like

Same issue here. Actually windows with Transluscent materials are blocking my Lumen global illumination behind them completely.

Furthermore, raytraced reflections on those transluscent materials are reflecting non-lumen, unlit variant of the objects.

1 Like

Because dx12 is not turned on,all reflection an galss effects,are not good,

1 Like

I have the same issues with Glass material, please someone explain how we could get good result with glass? Do we need to change translucency option in post process volume to raytraced? because when I do that the engine will crash…Right now I don’t have any reflection on a translucent material. thanks

Thanks, will try that !

EDIT: I am already targetting DX12, and I made sure to tick only DX12 (SM6) but that doesn’t solve the problem. Did you actually get it to work ? Did you do anything else than switching to DX12 ?

By default, the light shadows are “PROJECT DEFAULT”, on Cast Ray Traced shadows options. MUST BE DISABLED to work whith virtual shadow map (or shadow map).

glass material issues ,
the default (starter content glass material ) has its ior value set to 1.4 maybe great for a vase or other glass object ,
but when used as a window , looking at it almost side on gives reflections from behind it ,

lighting issues , light though glass if a single plane is used gives incorrect illumination , using a 3d mesh (2 sides with a small thickness distance between them gives much better results )
although it still gives incorrect shadowing on the ground , that is relative to the external global light source position ,
as much as i have tried i have had no luck in getting the light through the windows to give the correct shadws on the ground , ho btw i get the same results with hardware raytracing on or off with lumin



above all with ior(refaction) set to 1

with default refaction of 1.4…

vers refaction of 1


although it dose not solve the shadow transparancy issue it does resolve the refection issues

In case people are still struggling with reflections on translucency make sure you have these ticked in your project settings.

So High Quality Translucency Reflections is working for me. But how to add imperfections in your glass material?
Anything I’ve tried (multiplying in a Roughness or Emissive texture, etc) doesn’t make any difference.
Is this due to the Shading Model being used?(Thin Translucency)

I can’t find “High Quality Translucency Reflections” in my Project Settings… perhaps it was removed in 5.0.0?

2 Likes

Guys! After all night I´m excited to say I solved the problem here and I hope it help you.

  1. Your material as always as Traslucent/ Ligthing Mode/ Surface TranslucencyVolume

AND

In your Post Process Volume/ Translucency/ Type/ Ray Tracing

and that´s all! A nice reflections would be appear in your preview Viewport!!

Okay, so it turns out this is being caused by several issues and to fix your individual problem you have to track it down independently, everyone that submitted a fix here is right in their own way. I found that the issue, in my case was that glass materials were applying to the mesh, but not rendering on the mesh at all. Turned out I had to disable Nanite on the mesh and then click Apply Changes directly below, in the details.