UE5 Pixel Streaming 1.0 Update & Fatal Error WebRTC

Worked on a Pixel Streaming test a few weeks ago, set up to work on AWS. Worked great with everything working perfectly.
A few weeks ago the application suddenly started throwing “Fatal Error” alerts on pressing play on browser connections. I’m assuming this is due to similar WebRTC issues that we had earlier in March.

Now I’m stuck with a broken project which I can’t downgrade to 4.27, where the plugin is now 1.0 and stable.

My question is, is there an EA update coming to UE5 to update the Pixel streaming plunging to 1.0, or will it be kept as beta until release? Also is there a way to port the plugin from 4.27 to 5 as a quick solution?

I’ve tried this myself by transplanting the plugin from 4.27 to 5 plugin folders without success, has anyone else found a solution or is it even possible?


Looked at the UE5 source code and the 1.0 plugin is added. Just need to wait for release.

I’ve translated 1.0 plugin to 5.0 source branch and was only able to get things working by setting Default RHI to Direct X 12.

I’ve managed to get both WebRTC and Fatal Error also, did a write up of my experience with AMD GPU here Workaround Pixel Streaming 1.0 on AMD: fatal error, EXCEPTION_ACCESS_VIOLATION, crashing, blank screen and "webrtc waiting for video"

Keen to hear if this solves your issue also.