[UE5] Niagara System MISSING Initialize Ribbon

I am trying to create a Niagara System with a Ribbon renderer. When I go to particle spawn and try to choose “Initialize Ribbon” it does not exist. Am I missing something? I have the Niagara plugin enabled, and I’ve chosen “Ribbon Renderer” under Render. I have also added Starter Content as was advised by someone else, and nothing changed.

Hi, in the Initialize Particle module you can find all the initializing type above the header, just switch to Ribbon.

2 Likes

Sorry, which header do you mean? I’m not sure how to “switch to Ribbon.” I’ve chosen “Ribbon Renderer” at the bottom and it makes no difference.

I’m sorry, I didn’t explain myself. You just use the same module for everything, it is called Initialize Particle but it does it all.
The options under Point refers to every renderer, then you have different options for every renderer. If you use a Ribbon Renderer you will have to specify at least a Ribbon Width.

Thank you for the clarification.

Yes, I am trying to use a Ribbon so I CAN add ribbon width. I’m trying to do a rainbow/trail sort of thing, and all the tutorials I’ve found are mentioning using a Ribbon. My issue is that it doesn’t even show up in UE5. It definitely does in UE4.27.

I appreciate your help though!

Bump,

Hello, guys please if someone know to answer. I’m stuck also there…from 2 days i’m looking all over youtube all of them can add Initialize Ribbon in the Particle Spawn but i cannot find it.

It is in UE5. What you need to do is click on “initialize particle” then on the right side there will be a category called “ribbon attributes” then under that you will find “ribbon width” switch that from unset to direct set and it will let you specify the width of the ribbon. I guess they just got rid of the initialize ribbon.

2 Likes

Del the original “initialize particle”, then add it works for me.

1 Like

I saw a tuttorial, where only initilize ribbon works. So any ideas how to return it?