UE5 needs more memory than UE4?

Does UE5 require more memory than UE4? On one project, I tried to create a large landscape terrain but I got a message about running out of memory and UE5 quit to desktop. My computer has Intel I5 4670 CPU, 16GB of system memory, GeForce GTX 1070 TI GPU, and SSD drives.

The engine should use Windows pagefile (virtual memory) when you don’t have enough RAM. Try increasing it if you have free space on your drives. I think it’s because world partition cutting landscapes in small proxies need a lot of memory. I had to increase my pagefile to 100GB to import a really large tiled landscape without crashing.

Virtual Memory is set at 64GB and page file is set at 48GB. Should I change these settings?

Your RAM is not the issue, it’s your VRAM. Your Graphics card has a very limited amount of VRAM and this is 90% of all headaches, confusion and crashes related to the editor. Your 16GB of RAM should be adequate to run the engine, but your landscape textures are maxing out your GPU.

I’m not sure this is entirely the case, actually. The demo, by all rights, is extremely memory-heavy on both fronts, yet my 2060 Super basically got to the end of it in PIE before crashing (which I’m sure was more to do with loading it off massively slow external magnetic storage than anything). The 1070 Ti and 2060 Super have the same amount of video memory.

Shortly before the engine hard crashed on me, I checked my system memory usage–floating around 20 GB (out of a possible 64 GB in my machine). I’ll have to do more testing but it may not be as simple as “not enough video memory”.

Or it could be… there’s a reason we have all been trying to get a 3090 since it was released.

Either way the new test project lists the required specs. And it is rather memory intensive.

It seems like the new world tiling system thing is just always loading everything in memory when the editor is running.
So since you can’t set it up like in Kite, where you would only load one tile at a time to edit, you are definitely obligated to get more ram, vram and CPU - if the intention is to work on large scale projects…

Note that a 1080ti is barely reaching 30fps almost 4k native for the demo.
On 64ram and the latest i9.

I have a GTX 1060 6Gb and was able to import a 32k resolution heightmap so I don’t think VRAM is the problem here. It took 15 min and 64Gb RAM + almost 100 Gb of virtual memory but it didn’t crash

Open the Windows task manager and highlight “memory” in the performance tab, then look at the “committed” numbers while importing your landscape. If importing the landscape fills all of this memory, then increase your virtual memory.

1 Like

You can use Diagnostics tools from Visual Studio.

Mine is around ~5.3 gb.

I wrote two big messages detailing my memory usage experiencing a repeatable example of this error… then it was obvious. I looked into my virtual memory settings and found I had it set at 5 GB at some point. (I have 32 GB RAM and a 3090 RTX).

The solution was to up the Virtual memory to a fixed 32GB, and the “no video memory” stopped happening.

There’s the answer. :slight_smile:


Sorry to resurrect a very old thread but I’m doing it to mention I have found similar issues with VRAM usage in UE5 vs. UE4.

I started noticing issues a while back so I decided to try and narrow it down to see if it was some feature, setting, or objects in my scene.

I started with turning off Lumen, getting rid of all the Nanite assets, and then disabling Virtual Shadow Maps.

There was no effect, so I then went on to remove all instanced foliage assets and Landscape Grasstypes. Then I went to delete the postprocessing and cull volumes, and volumetric clouds. Then the height fog. Then the landscape. At this point, this was pretty much all that was left in the scene. In the end I was left with this:

So I shut down and re-loaded the empty scene. My VRAM? Nearly Maxed out. I thought, ■■■■…that’s pretty odd. Then I disabled Temporal Super Resolution and any other new features I could find, which also made no difference. So I then decided to see if it was a problem with my assets, or possibly the UE5 engine itself (by re-importing all of my assets into UE 4.27).

Naturally after bringing everything into UE4, I found absolutely zero performance issues. I even re-loaded the same heightmap-generated landscape and brought assets into the world. In fact the difference in VRAM usage to open a completely empty scene in UE4 vs. UE5 was about *2-4GB.

So I am fairly certain this is something to do with UE5 EA. Unless disabling these functions is simply not working, as far as I can tell it is not related to Lumen, Virtual shadowmaps, temporal super resolution, or nanite (which have been the main culprits many people have pointed to as the source of slow performance in UE5).

Having the same problem… This is with 5.1. Nothing I turn off or delete lowers my VRAM usage.

The issue was resolved for me after 5.0 full release and the hotfixes that followed, so suspect what you are experiencing is a separate issue.