UE5 name.project requires a temporary target.cs to be generated (Water plugin is enabled)

Hey all,
I have been trying to build and package my creation following the guide on Releasing Your Project | Unreal Engine Documentation
However since I am using the water plugin in UE5, I am getting the error:
"ProjectName.uproject requires a temporary target.cs to be generated (Water plugin is enabled)
ERROR: Client target not found!

Does anyone know how to make that temporary target.cs file it needs to build and ship my project so that I can share it with a friend?


Hey !
Do you find a solution ? I have the exact same issu with another plugin in 4.27.2.

I can’t package :confused:

Had this issue with ApexDestruction, OnlineSubsystemSteam and SteamShared BUILT-IN plugins in 4.27.2 as well so it’s not new apparently but I guess it works for others? FIrst I’ve thought that since I’m using Victory and AdvancedSessions, those might be at fault but when removing those but telling the project to still include eg.ApexDestruction it still failed. On the other hand there are some built-in plugins that are enabled by default (eg.steam VR) and they happen to cause no problems?

Tried adding a copy of these problematic plugins to my project’s plugins directory but that causes a conflict while moving the custom plugins into the engine’s plugin directory lets me enable them normally (and works in the editor) but won’t find them when trying to launch or package.

Also tried outright moving the ApexDestruction plugin’s directory from the engine’s to the project’s but still says it cannot find it, target.cs etc.

I did read you might need a win update for a similar issue to be fixed but that was an ancient article and on that note I did try installing a new version of msvC++ redist and .net as well but no use.
Someone also mentioned creating a fake/dummy target or c++ file there. Tried an empty target thing, didn’t work.

I kind of find if hilarious that the BUILT-IN plugins cause the problems, not the external ones… but my laughter isn’t truly genuine considering I have no idea how to solve this at this point other than hoping for an update that miraculously does so.

Sorry for the late reply, but unfortunately not no. I gave up trying to package it.

Concluded with a way more experienced UE user that it’s best to just wait for UE5 to be further developed and the water plugin out of alpha.

However by you having issues in UE4 I guess the problem may not be patched anytime soon and will be even harder to identify.

Yea, I’m not too hopeful either for now though it kinda further worries me that I rarely see similar errors on forums/answerhub - I’m afraid it is some problem on my end that is extremely hard to find, like something I installed or not or something hardware based. Probably not.

It’s still kinda weird, I mean I even tried this with the ThirdPerson example project and it packages/launches fine up until I allow either of said plugins. And of course PIE works perfectly fine as well. Weird stuff’s weird.

I have thought the same.

A good test would be to try installing UE on a clean machine and move a copy of your project there.

If the issue still persists I feel like it is fair to assume that it is definitely UE / something within the project that has gone wrong.
Could also try to create a new project using the same plugins etc. but on a different machine.

Just brainstorming a bit, unfortunately it put me off using UE for a bit and will have to return to it later. Had hoped I could go to UE4 instead of UE5 to fix it, but it sounds like that isn’t a viable plan.

On my side I did try it on a different machine and I even tried installing visual studio 19 and later 13 too because I seem to recall that in “olden times” VStudio itself was required to build. Not necessarily correct but matters not as it didn’t help.

Hi, I had same issue with Water plugin on UE 4.27.2 on Windows 8.1.

Solved it like this:

  1. Installed Visual Studio Community 2022 from here https://visualstudio.microsoft.com/ (during install it will ask package you want, I’ve chosen “gaming #2 - for unreal engine and other c++ stuff” )
  2. Installed Windows SDK from Windows SDK - Windows app development (I chose “download the .ISO”) (during install I didn’t touch any settings, all checkboxes were checked)

After that, packaging went without problems.

Errors verbatim for seach engines:

.uproject requires a temporary target.cs to be generated (Water plugin is enabled)
.uproject does not look like uproject file but no targets have been found!
ERROR: Windows SDK must be installed in order to build this target.

Interestingly enough, your approach solved the VictoryPlugin/ApexDestruction errors but not the SteamSessions one. There if I disabled the Sessions plugins, it allowed the dependencies to load fine but when the plugin was added its dependencies couldn’t load again.
Found my solution on Reddit, apparently after not so long ago UE stopped properly building the BlueprintOnly projects in certain situations and adding a dummy C++ class into it fixes it. Sounded like hogwash, tried it, worked. :face_with_raised_eyebrow:


1 Like

That solution sounded exactly as you put it: hogwash, but tried it anyway and it worked!

We had a BP only project and Windows packaging went through without problems but Linux packaging had this error related to PowerIK-plugin: ERROR: Missing precompiled manifest for PowerIKRuntime.

Thank you for posting your solution here!

1 Like

Same happens with Composure plug-in.

C:\Users\Moon\Documents\Unreal Projects\VR_ANOTOMY_01\Intermediate\Source

i dont understand, what i should to do? and show images too, please. thanks