Download

UE5 launcher wont launch, error prompt api-ms-win-downlevel-kernel32-l2-1-0.dll

installed ue5 early access engine several times, always prompting
error api-ms-win-downlevel-kernel32-l2-1-0.dll
on Windows 7 ultimate x64, (with)visual c++ redist 2005 - 2015 installed
tried the old fixes of updating windows update.
also tried adding that dll from windows page to “Epic Games\Launcher\Engine\Binaries\Win64” nothing seems to work for me.

Cant see anything about this for UE5, am i the only one?
UE4 4.25.4 works fine.

I’m having a similar problem however my download is stuck at 97%. I hope it works out for you my friend. Everyone should have chance to create to their heart’s content, develop what they dream of, and explore their imagination.

Thanks PxlBliss!
Figured it out, for anyone else having this issue
Just add that dll in your “UE_5.0EA\Engine\Binaries\Win64” folder, should do the trick.

New problem now, wont launch Sample game (Valley of the Ancient)
“DX12 is not supported on your system. Try running without the -dx12 or -d3d12 commang line argument.”

Dont know how to do that.
Any ideas, dont want to/can’t upgrade to Win10 just yet.

Hello !!
to charge directx 11 change just ValleyoftheAncient\Config\DefaultEngine.ini
line " DefaultGraphicsRHI=DefaultGraphicsRHI_DX12" in “DefaultGraphicsRHI=DefaultGraphicsRHI_DX11”

And it’s good !!!