Download

UE5 iOS r.MobileContentScaleFactor getting ignored

I’m after some help getting the correct resolution scale when building my project for my iOS device. I get the resolution I am after in 4.26, but when I make a copy of my project and build from 5.0EA2 nothing I have tried seems to get the correct resolution for my iOS device (iPhoneX).

I have added Config/DefaultDeviceProfiles.ini to my project (using the device Profiles Editor window) and set the following CVar for my device: +CVars=r.MobileContentScaleFactor=3

I have also tried (unsucessfully) adding this cvar for all iOS devices within Engine/Config/BaseDeviceProfiles.ini just to see if I could get any update to device resolution at all.

Unfortunately nothing I have tried gets my device to pick up the MobileContentScaleFactor, any help with this would be greatly appreciated!

Yes… I also experience that, the property is completely ignored, I have a iPhone 11, and it doesn’t scale to full resolution too, I supposed that is an engine bug, and I hope that it will be soon fix

This file Engine/Source/Runtime/ApplicationCore/Private/IOS/IOSView.cpp differs between 4.26 and 5EA. I removed line 277 setting RequestedContentScaleFactor to 1.0, and also the app delegate which runs on the game thread and rebuilt the engine from source - this seems to fix - packaging for iOS with this updated engine obeys MobileContentScaleFactor, although I am not an engineer so am not sure what other implications of this change may be…

IOSView.cpp (27.6 KB)