UE5 - invisible child actor components

Hi, ive run into an odd issue and I was hoping somewhere could offer a suggestion: I recently moved a project over to UE5 and now most child actor components will become invisible once the project is played.

They arent flagged to be hidden etc, but something about making a well behaved actor a child actor suddenly makes it invisible at runtime.

as a test case, here is a button as seen in the editor. On the left is the button as a stand alone actor, and on the right its set up as a child actor inside an empty actor.

Once the game is played, you can see the stand alone component is fine, but the child actor is invisible for no reason ive been able to discern.

Ive tried this experiment on a fresh ue5 project and child actors work fine in that case.

Ive also ran the game as a simulation and messed with the flags in the actor during runtime, and futzing with a number of flags will suddenly make the child actor visible.

Could this be a result of a new streaming or visibility system im not familiar with?

Thank you!!

1 Like

I’m having the same problems.

OK! for me, I think it was something to do with the FPS level? I started a new level and it is working in there!

1 Like

My teammate and I also had this problem and, like @jaredmills said, it seems to stem from the third person and first person default levels. We haven’t tested what exactly causes this in these levels, but the child actors don’t disapear in a newly created level from scratch!

I am having the same issue. My original blueprint worked fine in 4.27 but after moving to 5.0 the child actors are visible in the editor and disappear when playing/simulating.

I then made two simple blueprints, one with a cube and one that added the “cube blueprint” as a child actor. I added both blueprints to the level and they both are visible in the editor but the “child actor” version disappears when you play or simulate.

I moved these to a fresh Third Person project and saw the same issue. I then created a “blank” project, added the two blueprints and this time both blueprints are visible while playing/simulating.

After investigating the “World Setting”, I noticed the blank project had the “World Partition > Enable Streaming” checkbox “checked”. I went back to the original project and checked the “World Partition > Enable Streaming” checkbox. After this, both blueprints are visible while playing/simulating.

After adding another blueprint… the first blueprint is still showing the child actors but they are not visible the second one (when play/simulate)…

so not a fixed… this was in a project based on the third person default project…

maybe this adds some info to the issue…

there must be some setting in the default third person project causing this issue, for now i will try the blank project and add the third person content to see if that works…

Interesting! I tried a new level and discovered something interesting - a new “empty open world” map will manifest the invisible child actors issue. A new “empty level” will show the child actors as expected. While disabling “enable streaming” did not bring my child actors back in the problem levels, it does seem this may be streaming related. ill be reading up more on that system.

I think its a refresh issue , I add a child actor and simulate and it was invisible , after that I added a new blueprint to the scene and it shows the child actor this time , you have to add child actor â– â– â–  component then add the parent blueprint to the scene

Child actors need to have their Owner and Owner No See / other visibility settings properly set up to work.

They also need to use the parent’s bounds, and the partent’s collision must include them.

This is true for all engine versions, but they probably changed a default value on one of these options in more recent ones.

In the example above, the actor not having a visible mesh was likely the cause for the issue. No mesh means no bounds are calculated.
No bounds means the engine will cull the item out as it isn’t needed to render.