Ue5 game launch problem

Screenshot 2022-04-11 225849
Screenshot 2022-04-11 225904
My iGPU intel HD graphics 4400 paired with i3 4150 has problems with directx12.
even Fortnite gives the same error when rendering with direct x12.
Is there any way to specify the render direct x11 in ue5 for the game?

but to use Nanite and VSM you need dx12


( * Nanite now requires DX12 on Windows. DX11 is no longer supported.)
( * Virtual Shadow Maps now require DX12 on Windows. DX11 is no longer supported.)

I switched it but it is not rendering properly the water is black.
And there is a message lightning needs to rebuild in the shipping build.

fixed it, just rebuild the lighting.
I did not know the lighting is needed to be rebuild in ue5

I did set DX12 as the Default RHI in Project Settings, but that works only when I start the editor. When I start the packaged game, it’s still starting up in DX11 mode. Any ideas?

PS - I want that to be automatic, i.e. without using -dx12 command line switch.

How do you check what is the RHI running in the packaged game?
Please tell me the process
test by game : Release First Release · Paulastya2007/TheMedicBoat (github.com)
it is a bit buggy build.

console: r.RHI.Name

Actually I am having the same issue.
When the user lanunches the game for the first time in the menu it says dx12 but actually it is dx11.
I think them might fix this in the next release of ue5.