Download

UE5 Factories not showing up

Hello, I just want to report that factories in UE5 Early Access don’t show up in the Create Asset menu.

AssetFactory.cpp

In Editor:
image

In your factory override ShouldShowInNewMenu to return true.
Header:
virtual bool ShouldShowInNewMenu() const override;
CPP:
bool USuperDialogueAssetFactory::ShouldShowInNewMenu() const
{
return true;
}

1 Like

Still not working, the exact same code works in UE4
image

Hey - would you mind submitting a bug report via the Bug Submission Form?

1 Like

Just submitted a bug report :slight_smile:

Hi, I just did a test in UE 5EA and my factory worked ok, giving the option to create a new asset.
Did you create AssetActions for your Asset and did you remember to register them from your modules StartupModule() function?
I find that if no AssetActions are registered, your asset doesn’t show in the menu.
AssetInMenu

Edit: Just tried in 4.26.2 and my asset doesn’t show in the menu unless I register AssetActions there either.
I seem to remember in older versions we didn’t need to register AssetActions for the asset to show in the menu, but I could be mistaken.
Anyway, If you don’t have any AssetActions for your asset and you need any tips on how to create an AssetActions class and register it, let me know.

1 Like

I tried creating AssetActions and it worked! Thank you!
(I have struggle creating custom categories, there’s no much documentation about that, maybe you can help me :slight_smile: )