Download

UE5 Enable World Partition checkbox Greyed out

What am I missing, when I follow the documentation for enabling world partition the “Enable World Partition” box is greyed out.

The 2nd method in the documentation allows me to follow the steps, however nothing is enabled in my project. Am I missing an obvious step that is not documented?

i enabled it in the project settings and then it appeared enabled in world settings

Hmm interesting. I’ll give it another go. I tried that but wasn’t having any success. Was hoping it was something obvious. Thanks for replying :wink:

Same issue here, unsure what’s causing it.

1 Like

I’ve got the same issue. Have create d 3 different projects trying to get it to work. I can enable it in Project Settings but in the World Settings panel it’s still greyed out.

Same problem here, any luck resolving it?

Same problem, did Epic forgot to enable it?

1 Like

You need to enable World partition in your Project Settings, and after that create a new level, and It will work.

1 Like

When World Partition is enabled, then World Composition is grayed you, can someone tell me way Epic Grays out part you need? or do I miss something?

Hello everybody. Same situation here. Enabled in Project Settings but still grayed out in the editor. Created up to 3 new layers, no change. Did anybody find a solution? it’s driving me crazy.

Cheers

I have the same problem, something new?

I think the World Partition is the replacement for World Composition which is probably why that specific check box it greyed out and I think that the World Partition automatically handles loading and unloading of actors

I’m having the same issue. When I create a new level it adds a world partition by default, but the converter commandlet appears to be broken. It will say it succeeds in conversion but it doesn’t. Is there a way to migrate the contents of my old level to the one with the world partition? World partition seems to disable sublevels so that’s not an option. :confused:

@sbseltzer You can find in your Project Settings “Enable Conversion Prompt” option. If you enable it, when you open any level a windows pop out and will allow you to convert your level to WP. I couldnt convert my old level with commandlet, but this worked for me.

1 Like

@Byrpheros I already tried the popup. As far as I can tell the popup is just a thin wrapper for the commandlet since it has an option to select the commandlet class. Neither way works for me.