UE5 Early access Android SDK Version

Whenever I try to package or play the vr template from UE5, it Gives me this error: SDK Verification failed. Would you like to attempt the Launch On anyway? and then says Verifying sdk and device failed. It can detect my Oculus Quest 2 and I am using SDK 25 from android studio, I have looked around and found nothing about SDK’s or VR setup in general for UE5. Any Idea which SDK I should be using or whether it is some other issue?

1 Like

You have checked all the paths for android setup right?
NDK
SDK
Java and such

I just Installed the recommended Android SDK from Android studio, I didn’t add any paths.

Check project settings for the same.

Did you find a solution for this? I have the same issue trying to deploy on Android. Strangely when I clicked through and tried to deploy anyway it says it has been successful, but nothing appears.

Hi all,

After some trial and error I’ve been able to successfully deploy a UE5 Early Access project to my Android device. I’m also using the latest Android Studio installer, which is 4.2.1 as of the writing of this post.

First off, install the latest Android Studio. Then, there is an included .bat script within each UE install which you need to run which automatically fills in your project settings with the Android SDK and NDK locations and downloads the proper NDK, which right now looks like it is r21. The .bat location will look like this:
C:\Program Files\Epic Games\UE_5.0EA\Engine\Extras\Android\

From UE docs: “In the event that you receive an error stating that repositories.cfg cannot be loaded, navigate to the folder where it is expected (usually C:/Users/[Username].android/repositories ) and create an empty repositories.cfg file. Android setup should then proceed normally.”

So now back in UE5, plug your phone into USB port and you should see it show up under platforms. If you now try to run it, you will probably get an error about SDK verification failed. My log looked like this:

ATHelper: Verifying SDK and Device (Android): It was not possible to find any compatible framework version
UATHelper: Verifying SDK and Device (Android): The framework ‘Microsoft.WindowsDesktop.App’, version ‘3.1.0’ was not found.
UATHelper: Verifying SDK and Device (Android): - No frameworks were found.
UATHelper: Verifying SDK and Device (Android): You can resolve the problem by installing the specified framework and/or SDK.
UATHelper: Verifying SDK and Device (Android): The specified framework can be found at:
UATHelper: Verifying SDK and Device (Android): - Download .NET Core 3.1 Runtime
UATHelper: Verifying SDK and Device (Android): BUILD FAILED

So after I followed the link and did the install, then the verification error went away.

If you get an additional error like this:

LogPlayLevel: A fatal error occurred. The required library hostfxr.dll could not be found.
LogPlayLevel: If this is a self-contained application, that library should exist in [C:\Program Files\Epic Games\UE_5.0EA\Engine\Binaries\DotNET\AutomationTool].

I also installed this runtime to address that error

But the previous 3.1.0 link might fix both of these issues.

Good luck!

8 Likes

I needed to install the dependencies for Visual Studio 2019. The error I had was due to the .NET library not being installed.

thank you, installing both .Net Core 3.1 Runtime and 5.0 has fixed my problem, much appreciated

2 Likes

Hi, having similar issues, is there any difference if i downloaded visual studio 2022?
Or only 2019 will work?

1 Like

Hey, after spending days, trying to figure everything out. I managed to get it up and running on UE4 and UE5. I uploaded a Video showing the process.

Software reqs: Visual Studio 19/22 (doesn’t matter) with “Developing Games with C++” enabled.
Android Studio 4. Install SDKs and NDKs directly through Android Studio 4. I´m telling you, saves a lot of time. What SDK and NDK?


It´s telling you right there

And then set the SDK JRE and NDK path manually in UE5.

This works for AR / VR and Mobile Development. Hope I could safe someone some time!

2 Likes

now tou are a god for me

I do all that fixes and it is showing the same error: dotnet isn’t recognise.

LogTurnkeySupport: Completed device detection: Code = 9009
LogTcpMessaging: Started Connection to ‘127.0.0.1:6666’
LogTurnkeySupport: Display: Adding device menu item for PCANDRES
LogTurnkeySupport: Display: Adding device menu item for PCANDRES
LogTurnkeySupport: Running Turnkey device detection: ’ -ScriptsForProject=“C:/Users/Andres/OneDrive/Documents/Unreal Projects/PRUEBAV4/PRUEBAV4.uproject” Turnkey -utf8output -WaitForUATMutex -command=VerifySdk -ReportFilename=“C:/Users/Andres/OneDrive/Documents/Unreal Projects/PRUEBAV4/Intermediate/TurnkeyReport_2.log” -log=“C:/Users/Andres/OneDrive/Documents/Unreal Projects/PRUEBAV4/Intermediate/TurnkeyLog_2.log” -project=“C:/Users/Andres/OneDrive/Documents/Unreal Projects/PRUEBAV4/PRUEBAV4.uproject” -Device=Android_ASTC@1WMHHB645A2017+Android_Multi@1WMHHB645A2017’
LogMonitoredProcess: Running Serialized UAT: [ cmd.exe /c ““C:/Varios/EpicGames/UE_5.0/Engine/Build/BatchFiles/RunUAT.bat” -ScriptsForProject=“C:/Users/Andres/OneDrive/Documents/Unreal Projects/PRUEBAV4/PRUEBAV4.uproject” Turnkey -utf8output -WaitForUATMutex -command=VerifySdk -ReportFilename=“C:/Users/Andres/OneDrive/Documents/Unreal Projects/PRUEBAV4/Intermediate/TurnkeyReport_2.log” -log=“C:/Users/Andres/OneDrive/Documents/Unreal Projects/PRUEBAV4/Intermediate/TurnkeyLog_2.log” -project=“C:/Users/Andres/OneDrive/Documents/Unreal Projects/PRUEBAV4/PRUEBAV4.uproject” -Device=Android_ASTC@1W
MHHB645A2017+Android_Multi@1WMHHB645A2017” ]
LogTurnkeySupport: Completed device detection: Code = 9009
LogMonitoredProcess: Running Serialized UAT: [ cmd.exe /c ““C:/Varios/EpicGames/UE_5.0/Engine/Build/BatchFiles/RunUAT.bat” -ScriptsForProject=“C:/Users/Andres/OneDrive/Documents/Unreal Projects/PRUEBAV4/PRUEBAV4.uproject” Turnkey -command=VerifySdk -UpdateIfNeeded -platform=Android -noturnkeyvariables -device=1WMHHB645A2017 -utf8output -WaitForUATMutex -cookflavor=ASTC -EditorIO -EditorIOPort=61517 -project=“C:/Users/Andres/OneDrive/Documents/Unreal Projects/PRUEBAV4/PRUEBAV4.uproject”” ]
UATHelper: Verifying SDK and Device (Android): Running AutomationTool…
UATHelper: Verifying SDK and Device (Android): “dotnet” no se reconoce como un comando interno o externo,
UATHelper: Verifying SDK and Device (Android): programa o archivo por lotes ejecutable.
UATHelper: Verifying SDK and Device (Android): BUILD FAILED
LogSlate: Window ‘SDK Verification’ being destroyed
LogUObjectHash: Compacting FUObjectHashTables data took 0.28ms
LogPlayLevel: Launcher Device ID: Android_ASTC@1WMHHB645A2017
LogPlayLevel: PlayLevel: No blueprints needed recompiling
LogPlayLevel: Running AutomationTool…
LogPlayLevel: “dotnet” no se reconoce como un comando interno o externo,
LogPlayLevel: programa o archivo por lotes ejecutable.
LogPlayLevel: Completed Launch On Stage: Build Task, Time: 0.252965
LogPlayLevel: BUILD FAILED
PackagingResults: Error: Launch failed! Unknown Error

For anyone else trying to figure out why, “Cooking on the fly when launching from the editor” needs disabled in Project Settings - Engine Cooker. The engine returns a ValidationErrors > 0 since cooking on the fly needs disabled in shipping mode. Found the cause when debugging inside the UE5 source code.

This worked for me, thankyou, i had to modify both to get it working

I’ve done everything the communities around the internet instructed me to do to solve this issue, and installing the .NET Core 3.1 was the final key to resolving the issue. I can finally rest in peace. Thank you internet