UE5 does not let me import a heightmap, PLEASE HELP

Hello, please help.

For some reason I cannot import a heightmap into UE5. I am following the tuts, do everything they say, follow every single step precisely, and then on import the engine says that either ‘File type not recognized’ or 'File doesn’t have proper pattern (ex:_x0_y0.png)


I have tried 16 bit, then when it did not worked I tried 8 bit, I tried saving it in .PNG and in .RAW, I tried RGB and grayscale, - NONE of this worked.

However, if I download some image from the internet - it lets me import it nice and smoothly. If I re-save it with photoshop with 0 changes done - it fails to recognise it again.

Somehow I managed to import the test heightmap from photoshop by a blind luck - and it did not let me to re-import it afterwards. I also tried to export it, and it got exported in the form of several images:

each of them is accepted by UE5.

Can you please tell me, what should I do to normally import any heightmap pictures from Photoshop, as a part of normal workflow?

You just dont.
Photoshop doesn’t offer the ability to work or make 16bit files.

Why? There is a 16-bit option when you create a new file in Photoshop… And also every tutorial tells me to use just that. Why doesn’t offer the ability to work or make 16bit files if there is 16bit? I dont understand.

It does work. You have to make a RAW heightmap of the exact right size for the terrain you’re making – check the “total size” after you configure resolution and number of blocks.

The “_x0_y0” bits are about the naming of the files, because they need to have those names to match up the different terrain blocks.
As you can see from the error message, the name “Arkanir_WiP3” doesn’t end in those bits, but the file names in your second screen shot, do.

I have same problem, but day before i was able to upload any .PNG height map without any problem. Today i tried insert old height maps which was worked before and now i got same error.

Photoshop’s 16bit is fake.
Its 15bit+1, so it produces invalid files.

Also heightmaps aren’t drawings, they are sets of data. You should mess with them in an appripriate GIS program that handles the data,
Or at a bare minimum within a system that lets you work in 16bit native; try Krita, and probably GIMP.

Either way, the engine could be bugged too.
Export an heightmap from it, and try to re-import it. Best way to have a clean file to test for bugs.


It is the naming. Try not to use numeric in your file. Happened to me but I fixed it by renaming the heightmap file name

Hope it helps


i think there is a bug because i can not import any thing

but the button import didn’t work

1 Like

IT IS ACTUALLY THE NAMING!!! If you have everything correct, use raw files and a resolution that fits UE, rename your file and remove any numbers from the filename… omg :'D Will open a bug report on this!

edit: well it still doesn’t recognise the correct resolution -.-

1 Like

What do you mean “raw”?
All files are either PNG16 or just PNG.

Literally no other format should work (Nor can for the heightmap since you need 16bit).

a 16bit Raw file or 16bit PNG will both work.
They do need to be the correct dimensions however.

Check the Landscape Technical Guide in the docs.

Not a single mention of “raw”.

For anyone on here with issues, stick to png / png16.

1 Like

:clap: That’s right! Well done

Not really, UE picks the dimessions. One can make any size after all. doesn’t need to be square.
All though, it turns out, the numerical naming is an issue. Error disappeared after cleaning the numbers from source file name.

Be careful with that.
Non square landscapes have other issues with other things/components.

Usually because textures are all power of 2 squares - so when you cut up something to not be square and tell the texture to stretch over it you automatically get distortion.

This may not matter for the paint, but as soon as you do things more complex - like additive editing, or adding water - you get issues.

This is not true.
You should not be using random dimension sizes for Landscape, or “any size”.
For standard sizes Epic has a document that lists what the Recommended sizes are, and you should stick to only those sizes.
For World Partition terrains you should stick to only valid WP sizes.
For example, if you are creating a World Partition Landscape, during the import process, if you are not using valid World Partition dimensions, the editor will pad out your heightmap to a valid World Partition dimension, and that results in a stretched and padded edge to your terrain.
You don’t want that.
So you should always use a valid World Partition resolution.
WP Resolutions are calculated as (511 x N) - (N - 1).
Anything other than that sizing will result in a messed up Landscape.
You should also typically stick with a square size, or you could run into troubles.

Were you able to fix this? I also got the same issue, cant import some weightmap layers that are 1009.

I been using .r16 since UE existed… PNG files you also can use, its just not recommended in most engines and the industry in general…
Unreal Engine, does accept RAW format per Docs…

So not sure what your saying here…

What is important is making sure if your using an external terrain creator like WM, World Creator, GAEA, etc, is to per docs, set up your Z scale is set up. Now other warnings, errors, are a different story.

Make sure its 16 bit GreyScale… I see errors people all the time, they I worked with and help in various programs have these import issues, because they are not actually 16 bit, and they aren’t greyscale…

When exporting heightmaps from external programs, only the following formats are usable inside UE4.

  • 16-bit, grayscale PNG file
  • 16-bit, grayscale RAW file in little-endian byte order