Download

UE5 - Display Driver Stopped Responding whilst compiling shaders

Hi folks,

so migrated my 4.26 project to Unreal 5 to see how it looks with Lumen and whilst it is compiling shaders etc my screen goes black and switches modes, followed by system error ‘Display Driver Stopped Responding’ and then UE5 crashes. Something related to D3D.

Everything works fine in UE4.26.

Am using a GTX 970 card with latest drivers. Anyone know what might be the issue?

Fatal error: [File:D:/build/++UE5/Sync/Engine/Source/Runtime/Windows/D3D11RHI/Private/D3D11Util.cpp] [Line: 179] Unreal Engine is exiting due to D3D device being lost. (Error: 0x887A0006 - ‘HUNG’)

UnrealEditor_D3D11RHI
UnrealEditor_D3D11RHI
UnrealEditor_D3D11RHI
UnrealEditor_D3D11RHI

The issue is the GTX 970 card. I upgraded to GTX 1050 2GB dedicated memory and even that struggles.
The GTX 1080 4GB onboard memory will work.

The recommended minimum is an RTX 2080.
Your project DefaultEngine.exe needs to be reconfigured to a much lower output. You will need a PC with a Solid State drive and a 64 GB page file. The line in the UE5 code shows graphics card has detected a card memory overflow.

1 Like

Ok thanks for that Jim. Bit wierd because i’ve had ue5 working fine with other projects with the 970. But yeah either way it’s definitely time for an upgrade before UE5 is officially released.

1 Like

Same here with an RTX 2060…

Systems and GPUs feels like it should be a “solved problem,” but, really, it isn’t.

If you get a D3D / Driver error that blacks the screen like that, that is always, 100% of the time, a bug in the driver/kernel, or a problem with the system itself, not a bug in the game/engine/application.

Surprisingly, although we all like to blame those lazy BIOS / kernel / driver developers, a fair amount of the time, the problem is actually that the power supply is too weak, or the signal quality in the motherboard is marginal, or some component on the board is poorly soldered, or some hardware problem like that. For the longest time, I kept having occasional D3D driver resets on my graphics card, and I tried a large number of drivers and even upgraded the power supply, and nothing helped.
However, moving the graphics card down one slot (luckily, I have several 16x slots) seemed to work – I haven’t seen the problem in several days!

How is a normal human being supposed to debug these problems? The answer is, they can’t. Welcome to our high-tech future.

1 Like

Thanks for the insight. Ok my comp is like 11 years old now but still holds up today as it was pretty much the best you could get back then. Mainly use it for audio applications like Cubase, but since i got into Unreal i bought the 970 and it handles most things like a charm. One thing i noticed is the error i mention in OP is only on larger projects (say roughly 5gb or more). I can start a project in UE5 and it works fine. One thing i failed to mention is that i use my TV as the main monitor. That display mode switching sometimes happens in games i’ve purchased from steam.

When you mentioned about it being hardware related i think that’s the key rather than it being specific to my card. Pretty sure it’s not to do with the power supply in my case but my MOBO is ooollllldddd and it was only available for a year or so before Gigabyte discontinued it for some reason. A friend of mine put the card in so not sure if he could have put it in another slot.

What also makes me think it could potentially be RAM related is i get 'failed to uncompress …xyz/texture all the time in my projects in all versions. They can be fine for weeks and then an error comes up and i can’t load the game anymore without having to delete that specific texture.

image

Could be a hard drive that’s dying, too. Random read errors is a sure sign it’s time to make sure you have good backups, and think about what your next drive is going to be.
(hint: your next drive should be some flavor of Samsung EVO. Just sayin’. :wink:)