UE5 Create Event issues

Hi people,

I am having issues creating an event inside a function.
My function calls a “Bind Event to On Destroyed”. When dragging out the Event node, I call Create Event. After dragging the output of my bind event actor into the Create Event “Object” input, I select “Create a matching event” from the dropdown.

Afterwards, a new custom event appears inside my function, let’s call it “RespawnEvent”:

image

Now, when I search for the event in my “Create Event” dropdown, it just doesn’t appear:

image

Is this a bug or am I doing something wrong here?

Thanks in advance!

The object on your CreateEvent is the object in which you want to look for the correct event. So if you spawn an actor and put this actor in the object input, this actor needs the function. If the function is inside the blueprint where you spawn the other actor and not in the other actor, use SELF as object.


The function OtherBlueprint is inside the BP_TestActor


The function SameBlueprint is inside this blueprint (search here => SELF)

1 Like

Thanks for the hint of using a wrong passed object!

However, I still can’t make it work. After creating the event and trying to compile, I get the following errors:

image

And the event still won’t appear:

The event was created in the same blueprint where the BP Test Actor is being spawned.

Looks like the sig is not matching up; have you tried creating the event like so:

This should ensure the signature is correct.

Thanks for replying. Yes, that’s the way I create events, however this didn’t work out either.

For now I decided to rework the function to call functions instead of events which, for whatever reason, seems to work just fine.

Imho, it’s either a naming clash, an uncompiled blueprint or…

…are you doing this inside a function by any chance?! Probably not, seeing a latent node on display. I’d recompile both actors, get rid of the dodgy nodes and try again.

This has always worked in UE4. There is a chance this does not work in UE5 ofc, can’t help here.


You have this:

Which seems fine, what’s wrong with it? Oh that’s @L1z4rD89 pic, that’s the way to go.

Let me show you what happens:

2022-06-13 13-40-22

Full resolution:
2022-06-13 13-40-22.mkv (2.9 MB)

As above, recompile the blueprint. Dispatchers are finicky like that.

I did that before, however this only gives errors:

2022-06-13 14-13-17.mkv (3.4 MB)

Ha, that must be a UE5 thing then. Does it work without renaming?!

Nope, not even without renaming. Guess that’d be a classic situation for a bug report then?

No, you’re inside a function:

Can’t have an event inside a function. Place that event in the main Event Graph instead. My bad for not noticing it before. :expressionless: I kind of did:

…are you doing this inside a function by any chance?!

But I mixed up whose image belonged to whom. That would also explain nicely why binding to a function works.

1 Like

Oooh, there we go. I was already confused since I wasn’t able to create a Custom Event randomly. Alright, I guess I’ll stick to my functional rework then for the moment and maybe think about an event-y function later on. Thanks a lot!

1 Like