UE5 Crashing on rendering when using landscape and auto-materials

Hey guys,

Got a landscape from Gaea, with auto material on.

No matter what I do unreal crashes on rendering if my z-scale is set to something “high”, which is the correct number of what I need it to be.

I use this forumla:
For X,Y: 5000x100/res
For Z: 5000x100x0.001953125

Regarding the material itself:
I tried lowering the res, tried virtual texturing, still crashes.
Tried changing to different auto material, same thing.
it only work when it’s a super simple material but that doesn’t help me much since it’s a landscape…

It looks like the combination of the depth + the auto material is crashing it no matter what.

Anyone got an idea what can it be? I’m really bumping my head into walls.

Thank you!

Hey there @Mantrastic! Welcome back to the community! First things first, could we see the crash log? Does your auto material work on a smaller landscape on another map?

Hey! thank you for replying so quick.
I attached a crash log.
CrashContext.runtime-xml (182.4 KB)

Yes the auto material does work on smaller landscape, and in particular it works if I lower the z-scale, but that doesn’t help me much since it changes the whole look of the landscape.

Sometimes the crash also shows “GPUScene.InstanceSceneData’ is zero bytes in size”

Ahhh that’s honestly looking like it’s tied into a landscape issue I’ve been tracking, that when the map has very high Z scaling everything that needs that data breaks down. What I’ve been tracking is how heightmaps like that can effect landscape brushes like the water system, but it seems you found another component of it.

Tough thing is I don’t actually have much of a workaround for this one, as past a certain size the crash is inevitable even if you don’t go over memory.

I had a feeling this is something of the sort.

But how is it possible that I see millions of youtube videos doing the same thing, even huge open worlds, and no one reports on any issue?

Is there anything I can do from the textures side?

Thank you!

That’s the part that makes it harder, is that the crash itself isn’t universal. It’s a mix of environment, hardware, and settings. Otherwise you just get some incorrect numbers for high amplitude maps and usually it’s not extremely common issue if not using the water plugin or anything using landscape brushes.

It’s also possible that these two issues aren’t entirely connected.

How many channels are in your auto material? Below 12 and using the Shared:Wrap texture space setting is best for reducing overhead.

Never heard of “Shared:Wrap” how do I do that? care to explain please?

I do feel that it’s possible to fix it somehow via the texture side, because it does render when using simple material.

So every texture sample in the material would have to have this in their details as the sampler source:

This combines them as a single ref so you don’t go over the channel limit as easily and can lower overhead if your textures are pretty large.

Oh I see!
Is it possible that I have only 1 texture sample inside this all big auto material? I only see 1

Well, that didn’t help anyway

Hrm, unfortunate, you may be able to rewrite a landscape layer material and simplify it a bit if you can, try to apply it. If it works, that would point us in a direction.

I gave up lol

A month later, still can’t figure this out.

Sorry to hear that! I’ve run into another user since then that has the GPUScene.InstanceSceneData becoming 0 bytes somewhat randomly issue as well. Still unsure why this occurs. I took a dip in the source code but rendering adjacent code is a bit terse to say the least. Caught between calling it a bug but am hesitant (because on my weaker system I can do the same and the only error I get is that I lack the VRAM and it just slows down) and declaring it environmental.

I am also working on a landscape file and also came to this specific problem. Happen to found this treat and delved in with a buddy of mine what was going on. We speculated that something was going on with the material instance for the landscape file was not being fully loaded before the render Que start. Anyway I used this landscape file from unreal market, maybe the devs can do more testing on getting this fix? Dark Rock Landscape in Environments - UE Marketplace

I am getting GPUScene.InstanceSceneData crash error when I’ve scaled up a landscape to be much larger than it’s original scale.