UE5 crashed with fatal error, Invalid Date values Y:30828, M:9, D:14, H:2, M:48, S:5, Ms:0

Here is the issue. I tried open an old ue4 build game with UE5, it creates over 450 errors with no surprise but at least no crashing. But once I closed it, I cant open engine(ue5) from launcher or folder anymore. It gave me this error below. It looks like engine generated a wrong date/time format. Not sure if anyone had this same issue before. Thank you so much guys.

UE4 opens with no issue

#things already tried.
tried reinstall engine
tried delete all the cache/intermedia folders
tried changed PC time zone

Fatal error: [File:D:\build\++UE5\Sync\Engine\Source\Runtime\Core\Private\Misc\DateTime.cpp] [Line: 43] 
Invalid Date values. Y:30828, M:9, D:14, H:2, M:48, S:5, Ms:0
0x00007ffa43f1da84 UnrealEditor-Core.dll!UnknownFunction []
0x00007ffa442ed28e UnrealEditor-Core.dll!UnknownFunction []
0x00007ffa43d14320 UnrealEditor-Core.dll!UnknownFunction []
0x00007ffa268c34ba UnrealEditor-GameProjectGeneration.dll!UnknownFunction []
0x00007ffa268dacf7 UnrealEditor-GameProjectGeneration.dll!UnknownFunction []
0x00007ffa268aaff6 UnrealEditor-GameProjectGeneration.dll!UnknownFunction []
0x00007ffa268acdf0 UnrealEditor-GameProjectGeneration.dll!UnknownFunction []
0x00007ffa268bcada UnrealEditor-GameProjectGeneration.dll!UnknownFunction []
0x00007ffa658cecfb UnrealEditor-MainFrame.dll!UnknownFunction []
0x00007ffa374a12a7 UnrealEditor-UnrealEd.dll!UnknownFunction []
0x00007ff702af0cb1 UnrealEditor.exe!UnknownFunction []
0x00007ff702af0e8a UnrealEditor.exe!UnknownFunction []
0x00007ff702af3c4d UnrealEditor.exe!UnknownFunction []
0x00007ff702b05534 UnrealEditor.exe!UnknownFunction []
0x00007ff702b086e6 UnrealEditor.exe!UnknownFunction []
0x00007ffacfed7034 KERNEL32.DLL!UnknownFunction []
0x00007ffad0f82651 ntdll.dll!UnknownFunction []

new update
machine stats
window 10
Nvidia geforce rtx 2070 super with latest driver (512.15)

So guys as for now be careful open heavy UE4(4.27.2) project with ue5(5.00) copy straight.( didnt know it will causing this issue), I think best way will be create fresh ue5 project and clean up your old ue4 project then migrate to this fresh ue5 project piece by piece

1 tried reinstalled launcher this time (reinstalled engine again as well) # issue remains
2 changed local PC time to a different time and year. # issue remains
I still cant open fresh UE5 from Launcher or from Binaries/win64/UnrealEiditor.exe
3 Only UE5 I can access to is from this specific UE5 copy of a UE4 project(this is also the project causing this issue). # notes here, I converted 3 projects from UE4 to UE5, only this one project can access UE5, the other two had same invalid date value issue.

New Update
Solved
we experienced with multiple machines with same built/pipeline in different projects. This issue happened randomly. We didn’t find any pattern. Some project we can open with no issue, some project had this error.
Then We went through and compared build file from 4.27.2 and UE5, here are paths # #Epicgame\UE_5.0\Engine\Source\Runtime\Core\Private\Misc\DateTime.cpp
#Epicgame\UE_4.27\Engine\Source\Runtime\Core\Private\Misc\DateTime.cpp
The code are different, so there might be a chance 4.27.2 Datetime.cpp causing the issue for UE5. (Maybe after converted UE4 to UE5, UE5 cant recognize correct Datetime.cpp or its getting a mix datatime.cpp) , So as for now be careful open heavy UE4(4.27.2) project with ue5(5.00) copy straight. Migrate if you can
How to fix?
1 we deleted whole epic game launcher, UE 4.27.2, UE5 (delete all the old versions of Unreal engine on your machine)
2 We deleted all the related projects created or converted with UE5 (both local and server)
3 We deleted all the sample projects created with latest UE5 (both local and server)
4 reinstall latest epic game launcher
5 reinstall only UE5 engine, (after download re-verity this UE5 again from launcher, just making sure here).
6 making sure all the PC time setting are correct.

I will continue update this if anything showed up.
Hope this will help you.