#UE5 CRASH #UE5 Unreal Engine 5 Crash, crash, crash.... Please helpe-me

#UE5 CRASH #UE5

Need help!
My UE5 has been bugged for several days.

I receive the following error message:

Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0x0000000000000018

nvwgf2umx
nvwgf2umx
nvwgf2umx
nvwgf2umx
D3D12Core
dxgi
dxgi
dxgi
dxgi
dxgi
dxgi
UnrealEditor_D3D12RHI
UnrealEditor_D3D12RHI
UnrealEditor_D3D12RHI
UnrealEditor_RHI
UnrealEditor_RHI
UnrealEditor_RHI
UnrealEditor_RHI
UnrealEditor_Core
UnrealEditor_Core
UnrealEditor_Core
UnrealEditor_RenderCore
UnrealEditor_Core
UnrealEditor_Core
kernel32
ntdll

[quote=“Dimi2017, post:1, topic:561621”]

Hi @Dimi2017

nvwgf2umx
D3D12Core
dxgi

These errors are Nvidia Graphics card errors. Please run the NVidia Driver update program to get the latest drivers at least 421.*

NVIDIA Update|NVIDIA

1 Like

Thanks fot the answer. But i

But I updated my video card driver to the latest version, and the problem still persists.

Hello Dimi,

Does changing:

Project Settings → Default RHI from DirectX 12 to DirectX 11 resolve this?

3 Likes

Unfortunately UE5 crashes before I can change the configuration. Maybe I have to buy another model of video card.
Thank you

I have the same…

if the engine is bugged, uninstall and reinstall?
a new update came out this morning as well so may as well get a clean install.

Hello again @Dimi2017

Since it’s crashing on launch you could try changing the setting by opening your Config/DefaultEngine.ini and changing ‘DefaultGraphicsRHI’ there.

[/Script/WindowsTargetPlatform.WindowsTargetSettings]
DefaultGraphicsRHI=DefaultGraphicsRHI_DX11

Hope that helps!

4 Likes

Hello hello there! If you haven’t gotten it fixed yet the following might work (at least worked for me) :

  1. Open NVIDIA Control Panel

  2. Go to “Manage 3D settings”

  3. Find the “Restore Defaults” in the upper right corner of the control panel

  4. Click it and you will get a pop-up and click yes on it.

6 Likes

thanks

Thank you sir, it worked. finally I can use UE5 :slight_smile:

2 Likes

PLEASE I NEED HELP!
what am i doing wrong? I am just starting with Unreal and when trying to open a new blank c++ project this error pops up:

An error occurred while trying to generate project files.

Running C:/Program Files/Epic Games/UE_5.1/Engine/Build/BatchFiles/Build.bat -projectfiles -project=“C:/Users/MegaTecnologia/Desktop/Unreal Engine 5 - Proyectos/MyProject/MyProject.uproject” -game -rocket -progress
Running UnrealBuildTool: dotnet “…..\Engine\Binaries\DotNET\UnrealBuildTool\UnrealBuildTool.dll” -projectfiles -project=“C:/Users/MegaTecnologia/Desktop/Unreal Engine 5 - Proyectos/MyProject/MyProject.uproject” -game -rocket -progress
“dotnet” no se reconoce como un comando interno o externo,
programa o archivo por lotes ejecutable.

Does someone know what this is about?

but isn’t this a temporary fix? if nvidia/unreal fix the bug in their next updates, wouldn’t we have to revert this?

Hi Michael,

YES. This is very much a temporary solution and should certainly be changed back to DirectX 12 once a fix is made. (I’d try re-enabling it every time a new version/hotfix for Unreal is released and every time you update GPU drivers)

1 Like

This error was only coming up when I was using my 2nd screen. In the Nvidia control panel, when I checked the unreal related exes, I saw that all of them had integrated graphics cards selected. When I made all of them nvidia video cards, the problem went away.

1 Like

Sorry, i have the same problem, but i can’t start a new project so i can’t find Config/DefaultEngine. Can you tell me where i can find it?

Hi @BestiaSuprema,
You need to change the Base system on startup then
go
notepad C:\Program Files\Epic Games\UE_5.1\Engine\Config\BaseEngine.ini
Control+F find “WindowsTargetSettings” at line 2874

[/Script/WindowsTargetPlatform.WindowsTargetSettings]
+D3D12TargetedShaderFormats=PCD3D_SM5
+D3D11TargetedShaderFormats=PCD3D_SM5
bEnableDistanceFields=true
bEnableRayTracing=true
bTarget32Bit=false

Add the line

DefaultGraphicsRHI=DefaultGraphicsRHI_DX11

so this looks like

[/Script/WindowsTargetPlatform.WindowsTargetSettings]
DefaultGraphicsRHI=DefaultGraphicsRHI_DX11

Save the file on closing notepad and restart UE Editor.
You system now uses DefaultGraphicsRHI_DX11

If this does not work you have a differrent problem and you need to start another thread as this one is resolved
The new Projects setting need to be updated to fix SM6 for Nanite error message in the post
New BUG (regression). for SM6

2 Likes

It worked! Thank you really much

I updated the Nvidia driver. Still keeps crashing.
I reset the Nvidia control panel to default, then select Nvidia.
No pop-up, or crashes.
Nice!

making the edit to UE5.3.0 worked

as outlined in this post editing this file
C:\Program Files\Epic Games\UE_5.3\Engine\Config\BaseEngine.ini
worked for me on my windows10 dell XPS 8920 workstation
intel(R) HD Graphics 630
driver version currently installed 27.20.100.8854

after launching UE5.3.0 click on the “no” button when the warning pops up