UE5 Crash on building streaming texture

You may be running low on VRAM is my best guess?

Does it tell you “No duplicate texture GUIDs found.” even after restarting the editor and running it again?

Yes, it does.

I tried to find the problematic assets inside the map, by deleting a bunch of assets at a time and rerunning the Build streaming textures until it worked, but I couldn’t pin point the problem. It did build after I deleted a whole bunch of assets but after I recovered the original map and only deleted the last chunk of assets I deleted the last time around it still didn’t work.

I think the issue tends to stem from duplicating textures in a way Unreal doesn’t handle well, so multiple textures end up with the same GUID. I’m not too sure why it would be giving you an error of duplicate texture GUIDs when all your textures are still reporting unique GUIDs.

  • My first idea would be that my program updated a GUID it couldn’t, so it thought there’s no conflict even though there is. In that case, I would expect the GUID to revert on an editor restart, so I don’t see that as too likely.

    • To address this, I could change my plugin to update the GUID of all textures with a matching GUID, rather than letting the first texture retain its GUID. However, to do this, you’d need to reset the textures to a state before my plugin previously updated them, so the program could know which ones to update.
  • My second idea I have is that my plugin doesn’t update the GUID of textures that have an empty GUID. The reason I have it this way is that otherwise, the plugin ends up trying to update a bunch of engine textures, but I haven’t had any actual issues when the plugin includes textures with empty GUIDs.

    • A simple change to the plugin should allow you to hit any textures that don’t have a GUID, although this will also result in the plugin always telling you that a texture has changed, since it will always attempt to fix the engine plugins (at least each time you restart the editor).
  • My last remaining idea would be that TObjectIterator (what my plugin uses to find all the textures) “does not include any class default objects.” Maybe if the problematic texture is an improperly copied version of whatever Unreal is considering to be a “class default object,” that could cause the issue? I’m not really sure.

    • With a bit more work, I could probably figure out how to get all class default textures, but I’m not too sure how to do that offhand. I’d assume they’d have an empty GUID anyways, so I’d assume the second solution fixes it. Otherwise, if you’d duplicated a “class default object” multiple times, solution one would also be enough.

I’ve made a version of my plugin on a new branch that has the fix for the first and second idea. It also includes the full path name of updated textures, which should help make debugging a tad easier.

2 Likes

Wow! You are absolutely awesome! The newest version of your plugin fixed my errors!
Thank you so much, I really appreciate you going the extra mile in helping out.

If you are interested in which GUIDs where updated this time around, here is the relevant part of the log.

1 Like

Assuming the log messages are accurate, it seems only engine textures were updated (outside of the media texture in the scripts folder, which purportedly changes every time). I’m very surprised that did the trick, as I didn’t think engine textures could cause any issues.

Very glad it ended up fixing your issues though! I’m a bit busy with other projects (I’ve had to downgrade from this version of Unreal due to other bugs), but when I get a chance, I’ll add a third button in the master branch that includes textures with empty GUIDs.

How do you install this plugin i’m really new to this, I’ve made a folder in the project folder called plugin but when I try to load unreal it says that its missing a module from a different version and closes it down ?

Kind regards

The plugin should be placed such that the .uplugin file is located at <Path to your project>\Plugins\GuidFixer\GuidFixer.uplugin

The Plugins folder should be next to (not inside) the Content folder.

cant boot ue5 when i put that into plugins that download

image

image

i’ve moved to the correct location but still the same error :frowning:

yeah i get the same thing

I get the same plugin error on 5.0.1

Do you (or anyone hitting this issue) have Visual Studio 2022/2019 set up to work with Unreal? I wonder if that may be needed for compiling the plugin.

I’ll put a download to a compiled version of the plugin in a few hours, but it will likely only work in 5.0.1 and on Windows (my computer is Windows 10, but it may also work on Windows 11).

Thankyou, even you trying is amazing i’m pulling my hair out at this point. I haven’t got Visual studio set up to work with unreal though

Yep, thanks for helping! No VS in my system. It may need it to recompile.

yeah no vs at the momment the amount of problems im having just no need for vs yet. plus im windows 11.

I’ve updated the plugin on GitHub to be a bit more thorough, and it now has a separate function for updating textures with an empty GUID.

A version of it already built for UE 5.0.1 on Windows can be found here.
I created the build on Windows 10, but hopefully it works on Windows 11 as well.

2 Likes

@davisctools
yeah mate works on windows 11. and works now with out having to compile/rebuild

you need to make it and throw in Ue Market as a plugin :slight_smile:

1 Like

I can confirm this works, your an absolute star !11 Thankyou

3 Likes

This worked for me! One texture was causing the crash at 35% building texture streaming, my project was a conversion from 4.27.2 to 5.0.1.

2 Likes