UE5 Bake Animation from Control Rig Not Working!

I’m trying to use the default ue5 mannequin control rig to make animations in the level sequencer and then bake to linked animation sequence. The animations in the level sequencer look fine, but after baking to a linked anim sequence, many of the bones seem to not move resulting in a very deformed animation!


It seems that bones which do move in the level sequencer simply stay put after being baked!
Feels like a local / global space problem since many bones are staying put relative to the body control bone (which is the only bone moving in the animation)

Oddly, baking to a pose asset works just fine:

So the screenshots from above are using additive mode:
But this is using absolute mode:

1 Like

Something is definitely wrong. I am experiencing exactly your same issue. I also tried creating a control rig from scratch: same issue.

Just for your information, I tried rigging the UE4 skeleton and with that it works with no deformation.

Hi man. Did you solve that bug? I am going crazy. Don’t know what to do. I have the same problem

Ok I found the solution:
The problem is that there are extra bones in the ue5 manny skeleton which seem to “not apply to the mesh” and you can’t control them in the control rig, but then when you bake the animation they persist and mess everything up.

The solution:
You can’t use the ue5 manny skeleton because of these bones, and subsequently the “out of the box” control rig. Instead you will have to make a new control rig that is based on the manny_simple mesh. Once you make this rig, you should see way less bones in the viewport and this means you are using the correct skeleton (even though technically they are all the same skeleton).

I recommend following this tutorial:

IMPORTANT: Make sure you derive the control rig from the SIMPLE MESH!!!


I just made sure the Skeletal Mesh was changed to the _Simple (when I started, it was on SKM_Manny, and that is what causes the extra bones).

It does appear to be a bone issue, and this is the simplest thing I could find to fix this.

1 Like

this problem is so aggravating. anyone find a fix? i’m not making a new control rig…

Simple mannequin fixed it