UE5.0.X fails to Generate Project files with dotnet/nuget issues

Running 5.0.x Setup.sh on multiple flavors of Linux (Ubuntu 20.04, 22.04, 22.04.4, CENTOS 7, etc) all fail when trying to generate Project/make files. When running generateprojectfiles.sh I receive -

/home/user/UnrealEngine-5.0.2-release/Engine/Binaries/ThirdParty/DotNet/Linux/sdk/3.1.401/NuGet.targets(255,5): error : Unable to load the service index for source https://api.nuget.org/v3/index.json. [/home/user/UnrealEngine-5.0.2-release/Engine/Source/Programs/AutomationTool/AutomationTool.csproj]
/home/user/UnrealEngine-5.0.2-release/Engine/Binaries/ThirdParty/DotNet/Linux/sdk/3.1.401/NuGet.targets(255,5): error : The HTTP request to ‘GET https://api.nuget.org/v3/index.json’ has timed out after 100000ms. [/home/user/UnrealEngine-5.0.2-release/Engine/Source/Programs/AutomationTool/AutomationTool.csproj]

The host can browse to the URL https://api.nuget.org/v3/index.json (DNS/HTTPS are good), SELinux is disabled, Tried multiple versions of 5.0.X, no joy. Tried installing Dotnet sdk, runtime, etc. Tried environmental variables suggested on other sites, still fails. Wondering if anyone else is experiencing this issue and or has resolved it?

Going to try to install the pre-compiled version, even though that is not what I want for my end-state.

I have solved this issue for myself. Some background, my host(s) are running in a KVM/QEMU hypervisor and the issue seems to be using the MACTAP(Direct-connect NIC). Switching the network connection to NAT seemed to resolve this, not sure if the script interacts with hardware at a low level, however once switched, compiles without issue or error now.