UE5.0 Android does not appear on Platforms

Hey there.
I have installed UE 4.27.2 and there, I can package games for Android.
I wanted to test UE5.0.0 but for some reason on Platforms, I get the message “Platforms With No Compiled Support Android” as you can see in the first Screenshot

What I did was delete in “Target Options” from epic Games Launcher Android, I reinstalled sdks, NDK, restarted the Mac, and then I added again the target platform Android.
However, I still get Android as a Platform with no compiled Support.

Btw, Android platform target is supposed to be installed as you can see

The weird thing is that on “Project Settings”, Android Platform does not even appear, as you can see in the next screenshot.

It is weird because this didn’t happen to me when I tried UE5 Early Access. Could you please help me?
Btw, Android SDKs are installed because I do some Flutter and Unity projects in the same Machine (MacBook Pro M1). Thanks


I have the same problem. Any solutions?

Do you have the Android Target Platform installed ?

Yeap. And then I remove it, reinstalled asks, added it again and still having the same issue (that doesn’t happen on 4.27) and it is really annoying because I also want to try Oculus quest, but without Android support, it is impossible

Same issue for me.
Want to test the VR template on Oculus quest 2.
Target platform ‘Android’ has been added as an option, SDK & NDK installed, I followed the documentation on how to setup for Unreal and the platform does not appear in the platform settings.

Same issue for me.

not available??

New Version Release 5.0.1
With Fix → UE-148881 UE5 Mac Binary build does not have Android as a valid platform

[UE-148881] (5.0.1 Hotfix Released)

I am currently Downloading new version & may be issue is fixed.
Will test & report.

This has been fixed with 5.0.1.

Thank you @batiacosta for reporting the issue, let us know how it works for you now.


When I check to build, it said The SDK for Android is not installed properly, which is needed to generate data. ( I already installed Android Studio and SDK&NDK , works fine on 4.27 )
Do you have the same problem?

With 5.0.1 Android platforms are available now, thank you

1 Like