Download

UE4Game-armv7-es2.so not building

Hello everyone ! I’m trying to build GitHub dedicated server working on Android.
I’m using laptop MSI GE72 6QC Apache. I have about 190GB free space on disc D and about 15GB on C. All GitHub files are located on disc D. I have installed Custom Visual Studio 2015 with all additions available (including SDK etc.). I made sure to have API 19 to API 23 with Android SDK Manager.

I’ve already done:

  1. link your unreal and github account as per: https://www.unrealengine.com/ue4-on-github
  2. download the zip source code of the engine: https://github.com/EpicGames/UnrealEngine/tree/4.10
  3. have Visual Studio express installed
  4. exact zip and run setup
  5. run GenerateProjectFiles.bat as admin
  6. open UE4.sln which will open UE4 source in Visual Studio
  7. Build windows 64 | Development Editor
  8. replace the two whole files from the pull request: https://github.com/EpicGames/UnrealE...ull/1820/files

Those steps ended up with success and I created 2 PC multiplayer projects working with few clients.

I stopped at:

  1. Build Android | Development
  2. Build Android | Shipping
  3. Now you can open your freshly built engine with the fix in place. Located: \Engine\Binaries\Win64\UE4Editor.exe

The problem is with Visual Studio 2015 > UE4.sln (from GitHub folder) >Android (Development)>Build (UE4)
and the result is:

TryingToBuildAndroidDevelopment.png
TryingToBuildAndroidDevelopment2.png

Same problem goes with Android Shipping. I’ve already tried reinstalling GitHub and Visual Studio dozens of times. Opening files on Admin and disabling my Windows Defender. I haven’t found the asnwer on the internet.

Any advice will be much appreciated.

setup.bat expects the NDKROOT environment variable to be defined so it knows to download the Android binaries. Just make sure it is set before running the batch file. You can check in Engine/Source/ThirdParty/Android/cxa_demangle/armeabi-v7a for libcxa_demangle.a to verify it detected it properly.

Thank you for reply. If I understood correctly I needed to define the path for files missing in the errors shown above to create UE4Game.so. I was playing around with “enviroment variables” for the whole system and VS options. My default setting are:

1.png2.png

I changed every NDK setting to ndk-r10e or ndk-r12b or ndk-r11c (which are the only ndk folders I have exept AndroidNDK64 folder) to simply match in “enviroment variables” and VS “options”. I was hoping that one of the folders contain desired files mentioned in the errors. Now I’m not sure if I don’t have the files needed or I need to somehow enable NDKROOT to include/download/install android files.

setup.bat runs Engine/Binaries/DotNET/GitDependencies.exe which will only download the Android binaries if NDKROOT environment variable is defined. You have it defined so try running setup.bat again.

It solved the problem. Thank you very much Chris. I understand the whole process now.