UE4Editor with optirun on Linux


I’m running Ubuntu 15.04 with bumblebee installed, I cloned and built the engine from the git repo, When I run the UE4Editor with optirun, first it starts nicely and smoothly, but after I select a project and it loads, my bumblebee indicator says that bumblebee is off now and the program starts running really slow.

I think the editor starts another program after selecting a project so it won’t run with optirun enabled.

Is there a solution for this?

You could load up your project directly without going through the Project Browser.

Specify the path to the project’s .uproject file in the command line after you call the Editor with optirun.

ie. optirun ./UE4Editor /path/to/my/Documents/Unreal Engine/MyProject/MyProject.uproject

Works like a charm, thanks