Download

UE4Editor with Linux, "No Compiler was found"

Hi!

Last week I was working with UE4 in Linux, running Ubuntu 14.10. Everything was working fine, and I got it to work with Qt Creator, following the steps found here. Then I decided to do a complete re-install of my system and installed Linux Mint 17.1 instead. So I cloned the git again, following all the steps to compile everything. Installed Qt Creator, cloned this to Engine/Plugins/Developer, added the two lines to Engine/Config/Linux/LinuxEngine.ini and recompiled everything. But I still get the “No compiler was found. In order to use a C++ template, you must first install an IDE to edit source code.” - error.

What am I missing? Is it not supposed to work with Linux Mint 17.1 (i.e Ubuntu 14.04). Everything else seems to be working fine.

i have the exact same problem.

mint 17.1 (ubuntu 14.04), compiled everything from scratch using the Qt fix from the “linux_known_issues” wiki page, and it still says it cant find a compiler.

you need to create the symlinks to clang+±3.5

ln -s /usr/bin/clang+±3.5 /usr/bin/clang++
ln -s /usr/bin/clang-3.5 /usr/bin/clang

also i usually install kdevelop to have an alternate editor

I am also receiving a similar error “No compiler was found. In order to use a C++ template, you must first install an IDE to edit source code.” in Fedora 21. I have installed kdevelop, but it still doesn’t work. Any help would be appreciated.

Thanks

I just hit this problem on Ubuntu 14.04 and took care of it with this oneliner:


cd /usr/bin;for f in clang*3\.5;do sudo ln -s $f $(echo $f|sed -e s/-3\.5//g);done

Same issue here, Ubuntu 15.10, created the symlinks with no luck.

Working on Linux Mint 17.1

I was having this problem as well on Linux Mint 17.1 Cinnamon 64-bit. After changing /UnrealEngine/Engine/Config/Linux/LinuxEngine.ini by setting the PreferredAccessor as shown below I was still having some issues.


[/Script/SourceCodeAccess.SourceCodeAccessSettings]
 PreferredAccessor=KDevelopSourceCodeAccessor

I kept digging and found my problem was that I had also changed the Editor preferences at Edit->Editor Preferences->Source Code->Accessor->Source Code Editor to CodeLite 7/8.x. After also changing this setting to KDevelop 4.x I resolved the error.

Although I did run the below commands from mapopa I do not believe this was necessary.


ln -s /usr/bin/clang++-3.5 /usr/bin/clang++
ln -s /usr/bin/clang-3.5 /usr/bin/clang

All, I had this problem as well. To let people know this was with using the Sublime Text plugin.

Running these commands did fix the issue:
code:


ln -s /usr/bin/clang++-3.9 /usr/bin/clang++
ln -s /usr/bin/clang-3.9 /usr/bin/clang

I believe it has to do with the plugins looking for the main version of clang on your computer to be able to be called with the name ‘clang’ instead of specifying a version.

Using UE4 4.18 and 4.19 I kept getting this error, not matter what I changed “PreferredAccessor” to. After debugging the editor I found out that it thought it should use CLionSourceCodeAccessor. And due to CLion not being in the default location (/opt/clion/bin/clion.sh) it failed.

Fix: Symlink the CLion install folder to /opt/clion

I think it would be good if these source-code-accessor modules were a bit more talkative in the logs, having to step through the code of the editor to find these things just doesn’t seem necessary.

Oak1980 is right. I’ve encountered with this issue now and I also checked the source code of UE4 all IDE’s has their own folder and their paths are hardcoded (not cool…)


    // Linux Default Install
    if(FPaths::FileExists(TEXT("/opt/clion/bin/clion.sh")))
    {
        return TEXT("/opt/clion/bin/clion.sh");
    }

This was found in


/home/cagdas/programs/UnrealEngine/Engine/Plugins/Developer/CLionSourceCodeAccess/Source/CLionSourceCodeAccess/Private/CLionSourceCodeAccessor.cpp

as you can see it expects clions to be in that directory but mine wasn’t because i put it in my /home/cagdas/programs directory.

And for example Kdevelop’s default path in UE4 is : /usr/bin/kdevelop but it wasn’t there even I’ve installed it with apt. Whatever. Like oak said there should be better logging or at least let us choose where our IDE is located instead of trying to guess.


sudo ln -s /home/cagdas/programs/clion/ /opt/clion


Creating a symlink fixed the issue on my side. Thank you oak.