UE4Editor.exe has disappeared!

I have a strange problem : UE4Editor.exe has disappeared. A minute back my project was running. I added a few more CPP files, closed it and I guess I generated project files a few times for another project and now none of my project run. I cannot even fire up the engine from the Launcher. And I am dead certain I did NOT delete the UE4Editor.exe file, its not in recycle bin as well… Attached are some relevant screengrabs.


Hello dsanjit,

I’ve never seen this happen before, but you should be able to restore .exe file by verifying your engine installation. You can do this by selecting the Verify option from the dropdown arrow beside “Launch” for your 4.13 installation in the Library tab.

I tried deleting the .exe for one of my installations and verifying to ensure that it would work and it restored it for me.

Hi Matthew
Yes the verify operation restored everything. This never happened in the couple of years I have been using UE4 !

I have been thinking as to what could have happened. I had the NVIDIA Flex source version of UE4 and a couple of projects were built using that (with code plugins). I then deleted that version and installed the 4.13 preview 3. I think I ran one of the projects and it complained that the plugin dlls were missing and tried a rebuild. The rebuild went through the run failed saying that the UE4Editor.exe was missing. I think this is a patching related issue perhaps. Anyways alls well now…