UE4Editor crashes at first run (initialization)

Branch and commit at which it happens: 5fd57546cc721650026801021de0be733d48a3e9@release (4.9.1-release merged in).

Log: link text

Happens every time. No variations.

Hey Arlias-

Just to make sure I understand, you built the engine from the release branch and it is crashing for you? At what point does the crash occur. Does the crash occur when trying to run the engine from another branch/build?


Can you let me know if you’re able to build the engine from the 4.9 branch? This can be set during the clone process with the following line:

$ git clone https://www.github.com/EpicGames/UnrealEngine -b 4.9

If you’re still unable to build the engine can you list the steps you’re taking to download/clone/build the engine?


it crashes/segfaults with these last lines from the log (Load UI at about 45%):
[2015.09.25-12.55.42:208][ 0]LogStaticMesh: Building static mesh EditorCube…
[2015.09.25-12.55.42:209][ 0]LogStaticMesh: Built static mesh [0.002190.2s] /Engine/EditorMeshes/EditorCube.EditorCube
[2015.09.25-12.55.42:228][ 0]LogStaticMesh: Building static mesh EditorSphere…
EngineCrashHandler: Signal=11
[2015.09.25-12.55.42:720][ 0]LogLinux: === Critical error: ===
Unhandled Exception: SIGSEGV: invalid attempt to access memory at address 0x00000002

Have not yet tried another branch, since I though the current release branch was the best fit for me. No problem in trying though… which branches would you like me to try?


Will try 4.9 branch as soon as possible. I’ll let you know.

Hey Arlias-

I just wanted to touch base with you and see if you’d had the chance to test the 4.9 branch for the same issue? It would be great to hear if the 4.9 branch worked for you however if you are still getting a crash when running then we will continue to investigate.


Sorry not yet. May day job has me kind of pinned down at the moment. Give me until the Weekend.

Hey Arlias-

I’ve not heard from you in a few days if the 4.9 branch gave you the same issue. For now I’m going to mark this as resolved for tracking purposes, however if you do have the chance to test this you can post a comment to reopen the post and we will investigate further.