UE4Editor-Cmd.exe crashed after launch

I just downloaded the UE4 editior, and when I launched it I received this error:

What should I do to resolve this issue? I already verrified the install a few times, no errors. I also ran this in admin mode, and I still get the error.
thank you,

Here’s my DXDiag.txt filelink text

thank you for any help you can provide! :slight_smile:

Is there any solution to this problem? I think other people have had this problem on the forums, but there doesn’t seem to be ONE definite answer?


Unfortunately your picture did not upload correctly, and I an only see a bit of Tim Sweeney’s chin. Can you please describe if the error message has any relevant information that could help us to troubleshoot this?


Thanks Stephen, I have no Idea why my image didn’t upload, I can see it right now in this post?
But I can upload a picture through imgur, it might help.


Are you able to see it now?

Here’s the link:


There is a hotfix at https://answers.unrealengine.com/questions/12375/crashreportclent-has-stopped-working.html that may help some people. It didn’t help me :frowning:

I noticed your card is “Intel(R) HD Graphics 3000”, is it supported?
Mine is HD 4670 and it still gives the same error as yours.

Same problem for me. I also compiled my own Editor from source code, but didn’t work either.

Then I realized that I always had problems with the integrated HD graphics of my laptop interfering with my Nvidia graphics card. So I went to the NVIDIA control panel and changed to the NVIDIA card (which is in my pic called “NVIDIA Hochleistungsprozessor” as I’m german :wink: ). And now it works for me!!

I hope that this may help someone.

It’s actually working now!
What mBeierling said, I had already switched over the unreal engine to nvidia high processing in the nvidia control panel, but I didn’t switch the Ue4editor-cmd.exe over to nvidia.
But everything seems to be working now, thank you! :slight_smile:

Problem fix,


Hi FakeTruth,

If you have ensured that you are using the settings used by the others and you are still experiencing an crash, then your issue may be different from the one being experienced in this post. In this case I ask that you please make a new post with as much relevant information as necessary, including your system specs and the information that you attempted the fix mentioned here and it did not work for you.


Hi. I have the same problem and this fix did not help for me. By default I always force my NVIDIA card to be used and I tried setting it per application as in the screenshot, but I still have the problem. :confused:

Add in performance “EU4Editor” & “EU4Editor-Cmd”

I have done this, thanks. Here it is: UE4Editor-Cmd.exe has crashed - Platform & Builds - Epic Developer Community Forums

I had the same issue. It’s because Intel 3000 HD integrated graphics doesn’t support certain optional features of DirectX 11.

To fix it and get the editor running on Intel 3000 HD, comment out the following section of code:


//if (InUsage & BUF_UnorderedAccess)
//	Desc.BindFlags |= D3D11_BIND_UNORDERED_ACCESS;

//	static bool bRequiresRawView = (GRHIFeatureLevel < ERHIFeatureLevel::SM5);
//	if (bRequiresRawView)
//	{
//	}

I haven’t fully tested this, but since it’s used for the GPU particle simulation, you can probably safely assume that that won’t work.

NOTE: Once I got it all working, it runs at 2 FPS. So probably still best to use a different computer.

Did you look at pull request #8? It addresses the same issue. It may not help the FPS though.

Sorry, what is “pull request #8”?

Sorry, it’s on github at
Fix crash when running on hardware that does not support UAVs. It was put up by an engineer at Epic.