UE4Editor become very very slow when opening projects

I don’t know what happened, but suddenly it becomes so slow when my UE4.27 editor opens projects, within 10s → more than 10m.
Some projects stuck at “0% - initializing…” with log “LogD3D11RHI: Loaded GFSDK_Aftermath_Lib.x64.dll”, others stuck at “75% - initializing…” with log “LogEngine: Initializing Engine…”. And there is even one project which can be opened with normal speed! WTF
This situation also happened when I created a new blank project, stuck at 75%.
Reinstall tried, plugins removed, computer rebooted, no use.
And UE5 works fine, only UE4.27 editor becomes slow.

Your editor might get corrupted try reinstalling it.

Have tried it, no help. Thanks anyway

Having the same issue, started last month. At first it wasn’t a big deal since I was working with art and barely using unreal (also I thought it was the project that was heavy), but now that I started a new project this is so annoying. I have limited myself only to use blueprints since with C++ I usually close and open the project frequently.

Got any lucky solving the issue?

This seems to be a common issue, for my desktop computer and my laptop both suffer from this.
A solution I found that can ease this pain temporarily is that every time this issue happens, open the Oculus Client and close it or just start the Oculus VR Runtime Service in Windows service, and the editor can boot normally, how strange! I don’t know why but it looks like UE4 editor has a headache and Oculus Client is a bottle of strong painkillers hhh.

1 Like

Solved. Disable all plugins in the Virtual Reality category in the non-VR projects and these projects will become normal. For VR projects, use the first solution I posted.


Thank you for your solution, never thought that could’ve been the VR plugin. Disabled and working fine now!

Thanks my G,