Download

UE4 & Windows 10 Cortana Framerate Hitches

I recently ‘upgraded’ to windows 10 when I built a new PC and I’m finding that having Cortana enabled is causing huge drops in the framerate when working in the editor or playing in editor (PIE). If I play as a standalone game, it’s fine.

It happens about once every 2 seconds and the frame will jump from ~10ms to 50+ and it’s driving me mad. So I completely disabled Cortana and that fixed it. 100% gone. Then I lost the ability to search throughout Windows and started having issues related to Windows forced updates and the fact that I’d completely disabled Cortana. So, I re-enabled Cortana and now the hitching is back again.

I can’t seem to find anything about this in the forums… has anyone else experienced this? It seems crazy that I’d have to do this. Any suggestions?

After a day of hair pulling, I’ve found the culprit to be the NVidia 3D vision drivers which I had installed with my new GPU. Downloaded new drivers and did a fresh install, without anything extra. While I knew not to install the GeForce Experience, as it’s known for causing FPS drops, I had no idea the 3D vision drivers could affect a non-3D application. Still not sure why disabling Cortana fixed this, but I’m happy to be able to work in smooth FPS peace again (with Cortana enabled).

How shall I disable Cortana Windows 10. I am following this video: disable Cortana Windows 10. Is this good to go ?? Please inform me.Thanks