Download

UE4 vs APEX Clothing tool (nvidia Apex SDK) : can't communicate with FBX Files?

Hi everybody,

I’d like to export a model from UE4 to a FBX File and import it into APEX Clothing tool from NVidia APEX SDK.
I know it’s functionnal using 3DSMAX ou Maya Plugin
But i don’t succeed with APEX Clothing tool
When i open the FBX File under APEX Clothing tool, it says: “File xxx contains neither XML nor binary data”

I try to convert this FBX file into multiple format, and in OBJ (Wavefront) file, i can open it with APEX Clothing tool. So i export APX/APB Files - but when i try to use it under UE4, i’ve the issue: “Failed to import APEX clothing asset from the selected file”.

Someone has already succeed in exporting from UE4 to FBX and import it into APEX Clothing tool to make an APX Simulation ?
What is the solution i’ve not Maya or 3DSMAX ?

Thanks in advance,

Have you already watched this video: https://www.youtube.com/watch?v=VW7M0f04RwQ ? :slight_smile:

Yes sir ! I’ve tried to use Blender to import/export in FBX, but i’ve the same issue: “File xxx contains neither XML nor binary data” under APEX Clothing tool

If someone want to try, here is the model: http://www.benicourt.com/angie.FBX
I try to animate hair of the character.

Export from APEX tool work for me, my only problem is the bug with the tangents.

Import from or Export To ? What do you mean when you say it’s functionnal. Have you test with my model ?

Hi benicourt, I imported your FBX in Blender, I checked if everything was right and then exported again as FBX. I loaded it in the APEX Clothing Tool Profile and it works.

Oh Great !
Could you send me a new version of the file or the parameters you use to convert it ?

yes of course

7c6bc5e701a1f737334baedcadd35157731b2222.png

The only change to this image is that you have to set smoothing to “none” and use Blender 2.73 (not even 2.73a)

Let me know if this works!

Oh thank you very much,
There was another problem, the “path” - i am under win 8.1 and the APX Tool don’t support path with [space] - first problem
Second problem: blender - i’m using a RC of 2.74 - there is no “Smoothing: NONE” - i can with the 2.73 like you tell to me.
You must select armature too for exporting - and i’ve to make a rotate X 90° before exporting
With all that things, it functions
Thank you ! It was a hard way (i’ve tried an hundred times with many changes)

I’m glad it worked!

BTW don’t bother with rotating the model: use my settings and in the “Properties” tab of Apex Tool check the option Z Axis up: it should works!

Yes, i’ve done that, with Z Forwar and Y UP, thanks :slight_smile: