Download

UE4 Version 4.7.6 Physic behaves different PIE vs. StandAlone

Hi, I posted this question on answer hub, but figure I gave forum a try.

I got a skeletalmesh with physics all setup in Phat editor.

The skeletalmesh’s collision presets is set to “CharacterMesh” and I noticed when I PIE the physic works fine. But when I play in standalone game, the physics stutter a lot.

With the same setting, if I change my skeletalmesh’s collision preset to “PhysicActor” then PIE and standalone has the same behavior.

Don’t know why charactermesh presets resemble this differences in PIE vs standalone.

Any help will be appreciated.

In case somebody encounter the same issue, according to the reply at answer hub:

https://answers.unrealengine.com/questions/216065/why-is-physic-behave-different-in-pie-and-standalo.html

ue4 physic isn’t using a fixed time step, which causes physics behave different under different frame rate. The answer suggest tweaking physic substep in the project settings.

Thanks Rit! This is something I feel like a lot more Unreal tutorials and documentation should make note of, it’s really important!