UE4: Unable to use URL into Media Framework Player

Hi, I’ ve followed this tutorial to play a video into the Media Player with a file and it works fine:

But now, if I try with a Stream I can’t make it work (final goal will be to use a GOPRO HERO video url).

I’ve tried the following (my video source file is in MPEG-4 Video (XVID) and MPEG Audio Layer 3 (mp3))
If I stream the file with a VLC and without encoding into another format it works fine on distant iPad or local 2nd VLC, but not working in Unreal with same url.

I’ve also tried creating url containing a file name with extension that would be more file-friendly for the Media Player(.wmv, .avi), but it’s not working too.

Could someone please help ?

No answer ?


You can try GitHub - ue4plugins/VlcMedia: Media Framework plug-in using the Video LAN Codec (libvlc). . It still in develepment and any pull requests are welcome!

OK thank you.

You are welcome.

Hi Arthur, I’ve tried putting the directory either in C:\Program Files (x86)\Epic Games\4.11\Engine\Plugins and in \Plugins directory but I have an error message:
“Missing or incompatible modules in VlcMedia plugin + would you like t disable it ?”
What did I miss ?
Do I have to build a full engine with this plugin Inside sources ?


Don’t put it into the C:\Program Files (x86)\Epic Games\4.11\Engine\Plugins .

Create directory Plugins in the folder of your project and clone repo into that folder.

For example, if your game is in the C:\Users\ArtUrlWWW\Documents\Unreal Projects\VideoTest\ , then all files of the plugin and directories must be in the C:\Users\ArtUrlWWW\Documents\Unreal Projects\VideoTest\Plugins\VlcMedia\


P. S. Remove plugin from the C:\Program Files (x86)\Epic Games\4.11\Engine\Plugins dir…

You can contact me directly by Skype ArtUrlWWW1 , or by Google Talk (Hangouts, Google Chat :slight_smile: ) by forpdfsending@gmail.com .

I have the same error message.

Missing or incompatible modules.
Here is the list of my files



Contact me directly by Skype ArtUrlWWW1 , or by Google Talk (Hangouts, Google Chat :slight_smile: ) by forpdfsending@gmail.com .

Hi Arthur, would it be possible for you to provide any assistance to me as well, i’ve also tried to do the same and end up with the same errors. I’ve already contacted you at the given mail address, forpdfsending@gmail.com

Any assistance would be greatly appreciated :slight_smile:


Is it your tests or private project?
If tests - please, share it on bitbucket.org or on github.com and I will try to help you to solve that issue.