Download

UE4 to Blender, export UE4 animations as .fbx

I’m fairly new to these tools, so its possible I am missing something but I am just wondering if anyone has been able to successfully export any of the provided animation files from UE4 (HeroTPP/Owen/ASP) to Blender and been able to play them in Blender? I wanted to attempt to try and create some variations of a few of the provided examples that are setup to hold guns.

Just recently with a updated nightly build (testbuild-blender-2.71-f2597ab-win64), I’ve been able to successfully import character models (mesh & armature) to Blender from UE4, but when I’ve tried importing an .fbx file that UE4 created from an animation all I see is the armature in the normal T-Pose with a single frame. I’ve also tried using the Autodesk converter to get it into a DAE file, but that method seems to corrupt the data cause when it imports back into UE4 as an .fbx the HeroTPP seems to have multiple heads and no shoulders. In addition when viewing the exported .fbx file it will not play in the Autodesk viewer, but appears to be in one of the frames that were in the animation.

Maya is not an option for me because I am working on what I hope will someday be a commercial product and don’t have the money for it.

I can speak to this a little. Although our artists have standardized on Maya, I personally am much more comfortable in Blender, so have done a fair bit of work with UE4 and Blender.

Blender FBX support has, historically, not been very good. The FBS SDK that games and commercial applications use to import FBX can’t be used with Blender, even though it’s free, because the license terms are not compatible with Blender’s GPL. As a result, Blender support for FBX is custom-written and created by reverse-engineering the format. The FBX format changes a little every year, however, so it’s a moving target and they’re unlikely to ever have full FBX support of all features.

The last two Blender releases have seen huge steps forward in the stock FBX importer and exporter, and I’ve had quite a bit of success getting FBX files from Blender into Unreal using the stock exporter. What I haven’t been able to get working is the round trip - exporting from UE4, editing in Blender, and importing back into UE4. The importer only brings in the mesh, not the skeleton. I’ve had a little better luck with the third party FBX importer available at http://blenderfbx.render.jp (but only for Windows). With this, I can import the model, but after I export and try to bring into UE4, it won’t match the skeleton to the exported model. I think it’s because Blender is inserting an additional root bone on export, so the skeletons don’t match. I’ve tried working around it by modifying the export script to no include the extra bone, but the skeletons still don’t match.

If you’re not worried about round-tripping, though, you should be able to get very acceptable results with a little tweaking.

I find the best solution is to export two files - one with just the mesh and armature, but without the animations, and one with the armature but no mesh, but with the animations. UE4 likes to import the model/skeleton separately from the animations. I’ve gotten it to work by importing the same file twice, but exporting two files works better.

These are the settings I generally use for the mesh/skeleton export:

54e191b57dc0ee11442c34f48b92ee5d55148372.png

For the skeleton and animation export, I use these:

17fdd2f3055bb09ae7179c84766fc132d86f1055.png

If you have more in your file than just the model, you should select the model you want to export in the 3D view and then check “Selected Objects” to make sure you’re only exporting the objects you want.

Be careful about “Apply Modifiers”, especially if you used a multi-resolution or subdivision surface modifier to generate a normal map. If you select this and have either of those modifiers in your stack, it will export a very high resolution model that’s not suitable for game use.

I hope this has helped.

as far as I know there is no way to import animations exported from UE4, you might be able to convert the fbx file into a format that blender can import but I haven’t tried it.

@jeff, there used to be a way to get the round trip working but you had to use the old exporter, although I don’t know if it still works.

Yeah Blender will not import .fbx animations only skeletons and/or objects.

Thank you for the replies everyone, I was afraid of that. I guess the term is round trip for what I was hoping to accomplish (modify a few UE4 animations, and create shortened anim files from the animations provided with the ASP pack). If I learn some other way around this i’ll update the topic.

Yes that definitely helped shed some light on the topic, so thanks again. By the way the nightly build that I listed in the topic will permit you to import both the armature & the mesh from UE4->Blender in case you are still looking to try that.

I plan to put some time into figuring out what the problem is, I just haven’t had the time yet, and it hasn’t been a priority, since our artists all use Maya. I do want the ability to go round trip from UE4 to Blender and back myself, though, so worth spending some time figuring out what’s going on.

You can use Autodesk FBX converter to convert from the exported FBX you get from UE4 to collada format and then import into blender. Not sure how viable that is, but I have confirmed that the skeleton is at least present when converting and then importing collada.

The FBX->DAE conversion is sometimes problematic. With 2.74, I find it’s better to use the FBX import in Blender. You can’t export back out and have it match the Epic skeleton, though - even if you add a root bone, there’s still an issue with bone orientation that causes the animations to not work.

Instead, I import all the animations I want into Blender and then re-export them all and use that instead of the stock Epic skeleton. Minor one-time hassle to convert stuff over to Blender, but pretty minor.

Hello all, i have a problem that relates to this thread, searching for a fix i found this but didn’t really help.
I am trying to export individual animation made in the action editor of the dope sheet in blender but with the presets showed up in the photos i don’t get what i need. First issue is that it gives me an incorrect naming of the animation when imported like for example it gives me the saved file name (HandsReload) then the name of the rig i have in blender (Rig) and after that it shows the animation name ( hands reload) so instead of just importing the animation with the name of the file it gives me this : handsreload_Rig_handsreload. Second issue would be that if i don’t check the NLA in the presets for exporting then i would get only the animation that i want with the correct naming but it doesn’t have the full range of frames , gives about 70% of the frames that animation has.
Hope that you guys can help me out with this weird issue and move on.
Thanks,
David.