Ue4 stuck at 45%

Heya, i have a big problem. Let’s go to the point.

I uninstalled Unreal Engine, then i installed it again but this time when the installation finished and i try to open Ue it gets stuck at 45%, i tried everything that there is online but nothing worked.

I tried uninstalling ue and installing it again but no.
I tried downloading Microsoft Process Explorer and the process is suspended.
I tried deleting caches but no.

Thanks for your time.

Well, i just let the computer do the process the entire night and half-a-day and that didn’t work very well, i already check the firewall and everything seems to be all right. I’m going to try the third answer you give me, i’ll keep posting. Thank you.

Pd: I have an i3 7100, amd r7 360 and 12gb ram.
I think that’s enough for this.

Well, didn’t work, any suggestions?

Hey there, sorry to hear you have this problem. You have said you tried everything but since I don’t know exactly what have you tried I’m posting a list of things/solutions you could try.

  • just wait for a bit longer, I read it can take some time for the engine to load first time after installation, someone said they waited up to an hour
  • try switching off you firewall (could be something stopping/sand boxing UE4)
  • someone tried this: “I deleted some files that are in DefaultEngine data\Config\DefaultEngine I deleted r.DBuffer=False In the line of [/Script/Engine.RendererSettings] I can open it again”

If you have an older machine it’s probably just going to take a while. There’s a lot of topics about this problem but I will just wait for a while.

Please do let me know when you find a solution/cause for this. Might help other people in the future.
Good luck!

There are a lot of topics on the subject. I don’t know what to suggest next.

I’ll drop some quotes from the topics:

  • If you want to check whether the engine is actually frozen or not, right click on the windows taskbar and select Task Manager, you should see UE4Editor and 3 ShaderCompiler instances each using ~25% of your CPU % (that’s for a 4 core CPU, if you have more there will be more ShaderCompiler threads). So long as they are active, UE4 is still loading.
  • you can try deleting your DerivedDataCache, should force share recompilation (X:\User\MyDocuments\Unreal Projects…)

Looking for any other useful information, we’re getting to the bottom of this!

well, i’m very grateful for your help, i’m gonna change my computer soon, let’s see if that helps. Thanks!

I take it none of the above worked… sorry I couldn’t be of more help and it’s no problem, sitting here and trying to solve some problems for people is a learning experience for me.