UE4 Stopped signing my iOS-builds (ITMS-90035 / ITMS-90034)

I’m using the same exact certificates for nearly a year without issues, with nearly a hundred .ipa approvals. Now, 15 minutes to two hours after uploading and being approved, my builds are retroactively rejected with the following:

Dear Developer,

We have identified one or more issues
with a recent submission for
TestFlight review for your app, “App”
X.Y (1.234). Please correct the
following issues, then upload again.

ITMS-90035: Invalid Signature - The binary with bundle identifier
‘com.mybundle.identifier’ at path
[My.app] contains an invalid
signature. Make sure you have signed
your application with a distribution
certificate, not an ad hoc certificate
or a development certificate. Verify
that the code signing settings in
Xcode are correct at the target level
(which override any values at the
project level). If you are certain
your code signing settings are
correct, choose ‘Clean All’ in Xcode,
delete the ‘build’ irectory in the
Finder, and rebuild your release

Best regards,

The App Store Team

I haven’t touched anything regarding Xcode, and all I’m doing is uploading TestFlight builds.

UPDATE 1: I zipped up the project and re-opened it from there, to start “fresh” without any cache or other possible things gunking up the works. Went to project settings - certificates looked a-ok. Compile and upload to App Store Connect, I get an auto-generated email:

Dear Developer,

We identified one or more issues with
a recent delivery for your app, “App”
X.Y (1.234). Please correct the
following issues, then upload again.

ITMS-90034: Missing or invalid signature - The bundle
‘com.mybundle.identifier’ at bundle
path ‘Payload/My.app’ is not signed
using an Apple submission certificate.

Best regards,

The App Store Team

It seems like there’s something wrong with the signing process itself, but there’s not much I can do to troubleshoot right now - my certificates are correct. Whatever cleaning up the cached stuff by zipping up the essentials did, the submission error code changed and is now instantly getting rejected instead of lingering in TestFlight for a while. For whatever reason, Unreal Engine just doesn’t sign my .ipas.

EDIT: Since UE straight up doesn’t sign my .ipas, how can I retroactively re-sign the compiled file? I know it’s possible, and quite common, but I’m having trouble figuring it out. Made a thread on Apple Developer-forum.

In the project settings, I noticed a new option under iOS called Automatic Signing. It was off, so I checked the box, and entered my iOS Team ID, and hit compile. Some time later, compiling fails.

UTAHelper: Packaging (iOS): Code
Signing Error: NameOfMyGame has
conflicting provisioning settings.
NameOfMyGame is automatically signed
for development, but a conflicting
code signing identity iPhone
Distribution has been manually
specified. Set the code signing
identity value to “iPhone Developer”
in the build settings editor, or
switch to manual signing in the
Signing & Capabilities editor.

UTAHelper: Packaging (iOS): Code
Signing Error: Code signing is
required for product type
‘Application’ in SDK ‘iOS 13.5’


PackagingResults: Error: Failed to
Code Sign

I’m not quite sure I understand what exactly is wrong. I am building for distribution (App Store / TestFlight), but it seems that something has switched to development?

The solution’s pretty heavy duty and not possible for everyone, but I finally fixed this ridiculous problem.
Deleted my account from Xcode 11.something and then uninstalled it (apparently it’s known to have issues with macOS Big Sur, such as randomly not caring about your certificates bc your login session is voided, and it’s physically impossible to restore it) (also deleted all residue hidden in /Library), revoked all my certificates, voided provisions etc. Downloaded a fresh copy of Xcode 12.something, generated fresh set of certificates and provisions, disable automatic signing in UE4, and compile. Everything’s working again :- )