Download

UE4.SLN not generated? -- Building from Source

Kinda gotta complain a bit about the lack of clarity of the documentation overall. Apparently there is a wiki, but, none of the links from its main page are wiki, and its discussion page is not editable.

Anyway, I’m trying to build the engine from source on Windows.

Following:

And its previous steps. I’ve been getting errors. It is not stated very concisely that Setup.bat must be run prior to GenerateProjectFiles.bat (that step is not even stated on that page). It does not seem to matter whether or not I use the GitHub Desktop program or not so far, and if I recall correctly, I did not need to use that in the past. Seems unnecessary and verbose.

Anyway, after I ran Setup.bat, and tried to run GenerateProjectFiles.bat, I got the following error:

C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\MSBuild\15.0\bin\Microsoft.CSharp.CurrentVersion.targets(321,5): error MSB4019: The imported project “C:\Program Files (x86)\Microsoft VisualStudio\2017\Community\MSBuild\15.0\bin\Roslyn\Microsoft.CSharp.Core.targets” was not found. Confirm that the path in the <Import> declaration is correct, and that the file exists on disk. [C:\UnrealEngine-4.16.2-release\Engine\Source\Programs\UnrealBuildTool\UnrealBuildTool.csproj]

The version of Visual Studio I downloaded by searching for “visual studio” and downloading the community version was missing Roslyn and the .net framework core SDK whatever stuff. I needed to redownload (a different version of) VS (the “bootstrapper”) from the following website (which allows you to install additional plugins including the Roslyn .net stuff), and install the .net framework plugin for VS (as seen in the video on the page):

This brings me to my current problem. I am no longer getting an error when I run GenerateProjectFiles.bat, however, there is no “UE4.sln” file generated on my computer anywhere.

Start the VS 2017 installer again, install these packages (also remove .net core package):

  • Desktop development with .NET
  • Desktop development with C++
  • Game development with C++

The windows 8.1 sdk also needs to be enabled under individual components.

that works thanks, i’m getting new errors when building now in VS tho. i’ll post them later. thx again zeblote

Untitled.png

here are the errors

https://answers.unrealengine.com/questions/600362/error-building-416-branch-from-source.html

Would opening the SLN file in notepad ++ and changing those lines would be what i want to do?

I tried changing the .H file referenced, in the first two errors, as instructed here
https://answers.unrealengine.com/questions/600362/error-building-416-branch-from-source.html

But it didn’t seem to work.

Untitled.png

See https://forums.unrealengine.com/showthread.php?148212-Need-help-for-building-the-engine&p=727271#post727271

+1. You’re awesome. Thank you.

You must make sure that the source code is locate at a directory named “UE4”, it means that the parent folder of the GenerateProjectFiles.bat is UE4.