UE4 seems to smooth out animation on import.

So here’s the animation: https://i.gyazo.com/4d4ca96e6a36e94e2d67051423d6f4a5.gif

And here it is inside of UE4: https://i.gyazo.com/c2dd445a8c8302eb2cf6cbc5b202ebdb.gif

Exported as a 60FPS FBX animation. The animation’s root had to be re-oriented to be z-up so they’d work properly, I have no idea why these are being smoothed. It’s as if frames are missing, but maybe it’s being converted to a 30FPS animation by Unreal Engine.

Keep in mind this is split in two, so the first part has been imported into the engine. I’m sorry for the terrible gifs. Hopefully they get the message across.

Please help! This is driving me crazy.

Any ideas? I’m completely lost.

I believe there is an import option on UE4, something about using Default Sample Rate, you could try importing with that off. Also; when you Export the FBX, in Max anyway, there is an option to Bake or Rebake animation, ticking this stopped me losing frames from the end of animations.

Hope that helps!

Yep, that works! Thanks!