Download

UE4 - Removing Area Class; "Nav Area Obstacle" doesn't work, after reloading Blueprints, it is selected again, why?

Hi, I´m having Navigation issues, because some overlapers in the scene have “NavArea_Obstacle”

image

After building nav paths, everything is green like if that “NavArea_Obstacle” is not a problem, but when I play, all IA in that area cant move, I have tried to remove that by choosing “none”, but after click “compile” in the BP, save, close the BP and reload, “NavArea_Obstacle” is back again…

image

Why we have a “none” option, if the BP completely ignores it, and how to safely clear “NavArea_Obstacle” to avoid navigation issues?

I’m having the same issue but I haven’t found a solution yet. Will let you know if I find anything.

Give this a try, it seems to be working for my problem.
Nav Fix

Make sure “can ever affect navigation” is unchecked for any and all collision boxes etc. that are causing issues.

It won’t change the area class resetting each time but it should override it.

In the first picture I shared, you can see that “Can Ever Affect Navigation is uncheck” wich is the first step, second step is to set area class to “none” if not, Overlappers keep blocking navigation… the problem is, 50% of the blueprints return to “Nav Area Obstacle” after compiling.

Sorry that it didn’t help you. For me it fixed the issue. I’m using 4.27.2 and after unchecking can affect navigation the nav area class is irrevelent as the forementioned setting ovverrides it for me.

Keep in mind that if you have multiple actors that you need to do this for all of them. go back and double check everything. otherwise, good luck.