UE4 'release' & wwise inegration 4.9: Failing to build

UE4 '4.9' with WwiseUE4Integration '4.9' works perfect!

But, I need in **UnrealEditor 4.9.2**.

Trying to build UE4 'release' with WwiseUE4Integration '4.9'.

Result, massive errors (136) on files:

GenericPlatformSplash.cpp, StringFormatter.h, StringFormatter.cpp

Error	1	error C2065: 'FStringFormatArg' : undeclared identifier	E:\Engine\Source\Runtime\Core\Public\Misc\StringFormatter.h	18	1	UE4

Doing the same steps as ‘4.9’->‘4.9’, what’s wrong?

Hey audiofire-

I’m not able to find StringFormatter.h in the engine code which leads me to believe that it may be on wwise’s side. After building the engine for 4.9.2 how are you integrating wwise with the engine?

Cheers

Doug Wilson

Hey Doug Wilson

I do the following steps:

  1. Download UE4 ‘release’ branch and WwiseUE4Integration ‘4.9’ branch

  2. Launch Setup.bat in UE4 ‘release’ branch

  3. Force merging branches: wwise integration content owerwrite UE4 existing content

  4. Launch GenerateProjectFiles.bat in merged folder

  5. Launch UE4.sln in Visual Studio 2013

  6. Make Build Solution

Same steps in merged ‘4.9’->‘4.9’ - success
In ‘release’->‘4.9’ folder – failed on Step 6

Replying your question:

GenericPlatformSplash.cpp - present in both branches

StringFormatter.h - present in UE4 ‘release’ branch

StringFormatter.cpp - present in UE4 ‘release’ branch

Hi,

The Wwise GitHub tree is a complete fork of the UE source tree. You simply need to fork the Wwise repo and follow the instructions in Readme.md.

I’m still new to the whole github workflow but according to the wwise instructions, the repo does not contain the full source code, so if you just fork that repo youre still gonna be missing files. Either way, I’ve tried that myself and it didn’t work, at least not on mac.

Did you figure it out? I’m using a Mac but I have the same problem as you with GenericPlatformSplash.cpp, StringFormatter.h and StringFormatter.cpp. Seems impossible to integrate Wwise with UE 4.9.2

What do you mean in your third step? After downloading both branches and running Setup.bat I tried to unzip the WWise download into the folder with my engine however I did not get the same error you mentioned when trying to compile the .sln. Looking at the download page for WWise, did you copy the SDK files / libraries necessary?

Overwrite all UE4 existing content on step ‘3’ from Wwise ‘4.9’ branch folder. Of course, all required files was copied from ‘Wwise installation directory’

Hey audiofire-

Are you by chance using a Mac? I noticed rob_gr mentioned being on Mac and it may be that this is platform specific (which would explain why I’ve not seen the same result).

Hey Doug Wilson-

no, using pc

I tried to follow your steps again and I have not been able to reproduce the issue you’ve described. Here’s what I’ve done in my attempts:

  1. Download UE4 release branch and WWise 4.9 branch
  2. Unzip UE4 folder to local drive
  3. Run UE4 Setup.bat
  4. Unzip WWise folder to local drive
  5. Copy WWise files into UE4 folder location
  6. Run GenerateProjectFiles.bat from merged folder
  7. Open UE4.sln and select build

Following these steps Visual Studio seems to hang rather than complete with or without an error. If you were able to compile successfully using the 4.9 branch rather than Release, it is possible that WWsie has not accounted for differences in the UE4 branches.

Hi audiofire,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.